Audi A5 Forum & Audi S5 Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hello all, i am asking a question which is followed on from the following issue someone else has fixed! (can be seen below)

My rear view and exterior side mirrors haven't been tinting for ages which has been frustrating me massively. After replacing the mirror and still having the issue i decided to do some proper troubleshooting and found that they tint just fine when the lights are switched to the off position and when switched back to the auto position it stops working again. Which after a google diagnosis, found someone had the same issue after converting to facelift LED tail lights by not connecting up a wire, so they did that and fixed it but didn't actually specify which wire was the issue!

The wiring kit i used to upgrade from halogen to facelift LED was from a guy on this forum who sells on eBay but i cannot remember his name? Maybe you can help if you see this message!

PROBLEM SOLVED!!!!! it turns out that i forget to connect a single black wire that came with the adaptor kit from Kutafec when I upgraded my halogen taillights to the 2013 + LED's... For months now I drove myself crazy trying to figure it out. Now I have my rear auto dimming lights (again)....
Any help would be massively appreciated!
 

·
Registered
Joined
·
517 Posts
Would that person be Jordy aka Baas J
 

·
Registered
Joined
·
680 Posts
Hello all, i am asking a question which is followed on from the following issue someone else has fixed! (can be seen below)

My rear view and exterior side mirrors haven't been tinting for ages which has been frustrating me massively. After replacing the mirror and still having the issue i decided to do some proper troubleshooting and found that they tint just fine when the lights are switched to the off position and when switched back to the auto position it stops working again. Which after a google diagnosis, found someone had the same issue after converting to facelift LED tail lights by not connecting up a wire, so they did that and fixed it but didn't actually specify which wire was the issue!

The wiring kit i used to upgrade from halogen to facelift LED was from a guy on this forum who sells on eBay but i cannot remember his name? Maybe you can help if you see this message!



Any help would be massively appreciated!
Hi, yes you need to connect 1 extra wire and that will fix it. I will post the solution here. It only happens if you upgrade from halogen to Facelift and an autodimming mirror is fitted. If you have headlight assist (the camera behind the windscreen) it doesn't occur.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
Hi, yes you need to connect 1 extra wire and that will fix it. I will post the solution here. It only happens if you upgrade from halogen to Facelift and an autodimming mirror is fitted. If you have headlight assist (the camera behind the windscreen) it doesn't occur.
Oh that's amazing! Have been pulling my hair out trying to find out what the issue was! Worked out that the mirror tends to stop working when the sidelights are switched on or the main interior light comes on!

Your are correct, no full beam headlight assist installed!

I am looking forward to the fix.

Regards
 

·
Registered
Joined
·
680 Posts
1: Remove the inside mirror, just turn it counter clockwise.
2: Disconnect the connector of the mirror, there should be a black wire on position 3 of the connector.
3: Remove the right hand side trunk cover panel by removing black cross panel, 2 floor luggage hooks. Remove the torx of the backseat release catch and the top right black plastic rivet. The cover is clipped to the car by 3 metal clips. Pull the cover inwards and it will come loose. Be careful not to tear off the fixation points.
4: Check the attached picture....remove the black tape from the main wiringloom at the exact same spot where the red square has been placed on the picture.
5: There will be multiple black wires in the main harnass, find the correct one using a tool (Voltmeter or such) to measure resistance. Stick one end in the mirror plug and use the other to pinch the black wires. If it beeps you have the right one.
6: If you have found the right black wire, cut it.
7: Attach (solder) the side (coming from the mirror) to the already present green/black wire on position 13 of the big brown plug thats on the BCM. See attached picture for the location of the brown plug.
8. Mirrors will work normal again now.
 

Attachments

·
Registered
2008 MY09 Audi S5
Joined
·
40 Posts
Hi, yes you need to connect 1 extra wire and that will fix it. I will post the solution here. It only happens if you upgrade from halogen to Facelift and an autodimming mirror is fitted. If you have headlight assist (the camera behind the windscreen) it doesn't occur.
Hi Baas,

this is what i needed! thanks for that. One question though, can you retrofit Headlight assist afterwards?
 

·
Registered
Joined
·
680 Posts
Yes, very easy. Especially if you already have the Canbus Extended Gateway.
 

·
Registered
Joined
·
680 Posts
Yes, fit adapters and code the lights and presto.
 
  • Like
Reactions: F12NCO

·
Registered
Joined
·
680 Posts
If you have options like Side Assist / Lane Assist / Adaptive cruise control....you are equipped with extended Canbus.
 

·
Registered
Joined
·
680 Posts
Then you need to install (switch your old one for exteneded one) for the headlight assist to work.
Gateways have component protection (CP) so have it swapped at a dealer or a friendly who knows how to code the gateway and remove CP.
 

·
Registered
2008 MY09 Audi S5
Joined
·
40 Posts
Then you need to install (switch your old one for exteneded one) for the headlight assist to work.
Gateways have component protection (CP) so have it swapped at a dealer or a friendly who knows how to code the gateway and remove CP.
Do you have a part number for reference? Would i need a camera for headlight assist or do i already have it? i have rain sensing wipers. Thanks
 
1 - 14 of 14 Posts
Top