Audi A5 Forum & Audi S5 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
Hey folks.

I'm still getting used to my new A5, and so far it's lovely - but I've run into a problem with the MMI system. I want to chuck an SD card in with some of my music on, and while everything seems to indicate that playlists are supported (like, the manual, lots of posts on here, and indeed the UI on the system itself), I just can't get them to be recognised.

I've tried creating them in iTunes and editing the paths to be relative (and absolute, assuming the card as the root), I've tried massaging the line-endings, and I've tried using MMItunes, which seems to be the recommended solution for Mac users... no dice - no playlist has ever appeared in the interface.

The music itself plays fine.

Any suggestions? Anyone else had this much bother?
 

·
Registered
Joined
·
2,353 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #5 ·
Hmm. Had more a play with this at the weekend.

Seems like my playlists were fine, it just takes the MMI a good 20 minutes before it loads them. This is the case even if I format the card and ensure the playlist files are the first files written to the card.

If I cut the music down to only a handful of tracks, the playlist loads in a couple of minutes. So I suspect it's trying to scan all the music files before the playlists are added.

Naturally this makes it completely unusable. Whoever implemented this part of the MMI software is an idiot.

So anyway, if anyone else is running in to this problem, I'd advise giving up until Audi fix the MMI software.

I'm using an old iPod instead.
 

·
Registered
Joined
·
2,170 Posts
Hmm. Had more a play with this at the weekend.

Seems like my playlists were fine, it just takes the MMI a good 20 minutes before it loads them. This is the case even if I format the card and ensure the playlist files are the first files written to the card.

If I cut the music down to only a handful of tracks, the playlist loads in a couple of minutes. So I suspect it's trying to scan all the music files before the playlists are added.

Naturally this makes it completely unusable. Whoever implemented this part of the MMI software is an idiot.

So anyway, if anyone else is running in to this problem, I'd advise giving up until Audi fix the MMI software.

I'm using an old iPod instead.
That’s odd, my playlists appear instantly. I have some albums that originated from three CD’s so I created a “PlayList” folder in the root of the SD card then a playlist.m3u file for all three CD’s so that play contiguously. So the play list file contain 25 tracks.

Download Playlist Creator 3.6.2 Rev 497

This is the Playlist creator I use and its well easy to use
+1. This is what I use too.
 

·
Registered
Joined
·
41 Posts
I'm interested to know if the MMI remembers the indexed tracks and playlist. Ie it takes 20mins but is this a one off time when you insert the SD card, or does it take this long every time you start the car?

Coming from a software background, the implementation should remember if it's the same SD card. If that's the case this method isn't so terrible. It will be running in the background on the MMI, and giving priority to other tasks. I'm sure you'd be peeved if the SD card loaded in a few minutes, but during that time the MMI interface was unusable!
 

·
Registered
Joined
·
2,170 Posts
I don’t think it remembers. On mine if I eject the SD card and put it back in all the tracks reset back to their filenames on the display. Once they have played once then they appear with the MP3 tag data name on the display.
 

·
Registered
Joined
·
41 Posts
Wow that sucks then. Hopefully the new MMI is faster so it won't take that long, or at least remember the playlists between car starts.
 
1 - 10 of 10 Posts
Top