Audi A5 Forum & Audi S5 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys, I've just changed the oil and filter on my audi A5 3.0 tdi 2011.
Ive done about 20 miles and the low oil warning has come on.
I topped up with 6.4 litres of correct oil.
I used an after market motoquip filter.
I made sure the small lug on bottom popped into to the hole on bottom of filter housing, replaced o ring on the top cap for new and torqued the cap down to 35 n/m or lb/ft I can remember but it was as stated. AND YES THE SUMPPLUG IS IN. ??
 

·
Registered
Joined
·
3 Posts
Remove the oil cap and dry the inside of the cap. This happened to me after an oil change and drying the inside of the cap corrected my issue.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I'll give it a try this morning. I found a thread on a Google search with someone stating it was actually more like 8.2l of oil needed when the filter housing is filled up etc.
I'll try the cap and if still same I'll try filling it the extra 1.25l it's requiring as per dash display.
Thankyou
 

·
Sponsor
Joined
·
2,384 Posts
Aye simpler sounds like you didn't add enough. While annoying, the dash electronic gauge is usually good enough.
 

·
Registered
Joined
·
1,608 Posts
Oil and filter change on the 3.0 TDi should be about 6.75 litres. :)

Get a dipstick too! Only a tenner from the dealer! :)
 

·
Registered
Joined
·
9 Posts
My 3.0 CCWA took about between 8 and 8.5 the last two services. I thought I'd left the sump plug out! Bought a dipstick for the second service to double check.

Sent from my GM1900 using Tapatalk
 
1 - 6 of 6 Posts
Top