Audi A5 Forum & Audi S5 Forum banner
841 - 860 of 973 Posts

·
Registered
Joined
·
217 Posts
So I believe right now I would need to go in green screen and check if there's an option for Audi connect and Google earth.

If not, then I need to update the firmware using EU package (mine mmi is RoW), and while installing, I need to check the option for Google earth.

Is the the right approach?


This is from another forum which is same process I completed.

In the green (hidden) engineering menu under /config set "Install Fair Mode". This will enable the dhcp server and DLinkReplacesPPP via USB. Under /diagnose/coding/internal_modules_1+2 deselect all the "online" choices.

For googleEarth it has to be installed but you can check this in green screen.

I don't know about firmware for you as I say I'm in UK, attempt a firmware update using your region. You don't have to update you can just see what it'll install and if 'GEMMI' is listed then install it an you'll not new European firmware.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
This is from another forum which is same process I completed.

In the green (hidden) engineering menu under /config set "Install Fair Mode". This will enable the dhcp server and DLinkReplacesPPP via USB. Under /diagnose/coding/internal_modules_1+2 deselect all the "online" choices.

For googleEarth it has to be installed but you can check this in green screen.

I don't know about firmware for you as I say I'm in UK, attempt a firmware update using your region. You don't have to update you can just see what it'll install and if 'GEMMI' is listed then install it an you'll not new European firmware.


Sent from my iPhone using Tapatalk


What kind of vcds cable should I buy? Is a USB KKL vag409.1 going to work on a6 2016? Or should I get a 5053 cable?
 

·
Registered
Joined
·
217 Posts

·
Registered
Joined
·
16 Posts
There's a script you can use to activate green screen I haven't personally used it but check this thread for updating 3gp maps it's on first

I would only recommend genuine VCDS, this was the tool I used.


Sent from my iPhone using Tapatalk


I've copied the green screen zip file but doesn't appear anything on the screen. But in Media -> Source, it recognizes it is a update medium, then I go to update mmi section, it doesn't allow me to apply the script since it's not a firmware package.

Btw, am I able to deactivate hidden screen with script?
 

·
Registered
Joined
·
217 Posts
I've copied the green screen zip file but doesn't appear anything on the screen. But in Media -> Source, it recognizes it is a update medium, then I go to update mmi section, it doesn't allow me to apply the script since it's not a firmware package.

Btw, am I able to deactivate hidden screen with script?


No idea how it works, as stated I used VCDS I had the tool there so was no need for the script.

Again no idea, but wth VCDS you can just change back so green screen isn't active but no point anyway useful thing to have.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
No idea how it works, as stated I used VCDS I had the tool there so was no need for the script.

Again no idea, but wth VCDS you can just change back so green screen isn't active but no point anyway useful thing to have.


Sent from my iPhone using Tapatalk
Ok, I've already ordered a VCDS cable.

Btw, do I need to enable some settings in green screen in order to get in red engineering mode?

Mine is 3GP and I tried to get in by holding car and back button
 

·
Registered
Joined
·
217 Posts
Ok, I've already ordered a VCDS cable.



Btw, do I need to enable some settings in green screen in order to get in red engineering mode?



Mine is 3GP and I tried to get in by holding car and back button


Not as far as I can remember, no green menu isn't required for engineering menu.

Car an Back button should get it up usually will say 'Loading green screen' along those lines.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
Not as far as I can remember, no green menu isn't required for engineering menu.

Car an Back button should get it up usually will say 'Loading green screen' along those lines.


Sent from my iPhone using Tapatalk


Weird, I pressed two buttons more than 20 seconds, nothing shows up. But I'm able to reboot the mmi in five seconds. I'm wondering if my dealer locked some functions up.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
217 Posts
Weird, I pressed two buttons more than 20 seconds, nothing shows up. But I'm able to reboot the mmi in five seconds. I'm wondering if my dealer locked some functions up.


Sent from my iPad using Tapatalk


Green screen won't be active if you have Prodution firmware I believe this was the situation for me.

As I say VCDS can activate or running a script but I have no experience with the script.

I've ran scripts before for things like map activation and it was required to wait a good few minutes for the MMI to fully boot.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
Green screen won't be active if you have Prodution firmware I believe this was the situation for me.

As I say VCDS can activate or running a script but I have no experience with the script.

I've ran scripts before for things like map activation and it was required to wait a good few minutes for the MMI to fully boot.


Sent from my iPhone using Tapatalk


I mean the engineering menu, how long should I be holding two buttons to reach the engineering menu?

Ps. I haven't activate green screen


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
217 Posts
I mean the engineering menu, how long should I be holding two buttons to reach the engineering menu?

Ps. I haven't activate green screen


Sent from my iPad using Tapatalk


For red engineering menu start by pressing car then immediately after press's back and hold both buttons for a few seconds. May take a few attempts to get in.

If your thinking todo firmware update I wouldn't without green screen as you'll want to enable user defined mode to be able to manually select of what to upgrade/install.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
For red engineering menu start by pressing car then immediately after press's back and hold both buttons for a few seconds. May take a few attempts to get in.

If your thinking todo firmware update I wouldn't without green screen as you'll want to enable user defined mode to be able to manually select of what to upgrade/install.


Sent from my iPhone using Tapatalk


Ok, so after I install google earth by user defined mode, I'm able to switch back to normal map?

I wouldn't need to update the whole firmware, but only install google earth by user defined mode


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
217 Posts
Ok, so after I install google earth by user defined mode, I'm able to switch back to normal map?

I wouldn't need to update the whole firmware, but only install google earth by user defined mode


Sent from my iPad using Tapatalk


Upon installing Google you'll be able to go into navigation settings and Google Earth will be a view option in the drop down box.

If it's not there go into green screen and check if it's installed by choosing 'get info gemmi' if installed then start the application persistent. It's pretty easy soon as you go into 'googleearth'.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
Upon installing Google you'll be able to go into navigation settings and Google Earth will be a view option in the drop down box.

If it's not there go into green screen and check if it's installed by choosing 'get info gemmi' if installed then start the application persistent. It's pretty easy soon as you go into 'googleearth'.




Sent from my iPhone using Tapatalk


Then after installing google earth, how would I enable to get tether network by USB to Ethernet and router?


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
217 Posts
For this to work I had to go in green green to /USB and enable 'Hub + iPod/USB Cable support'.

USB male Y splitter to dual female.
UGreen Ethernet USB adapter AX88772A chipset
TP Link mr3020

Here is mine connected up in the car.



First you'll want to set it all up plug into a computer and setup the router in WISP mode and connect it to your tether.

Connect all up in the car.
Green screen again to /config
Install fair mode.

Upon completing rebooted my mmi went back into green screen, checked /USB Ethernet adapter was detected.

Went into /config/console checked I had a IP address.

After this all working.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
28 Posts
Just to clarify... for the 3GP units (no sim slot)
The connection works like this?
AMI -> USB hub -> USB-RJ45 -> Router -> Cell Phone
--------------´
Is this correct?
So I would need for example the AMI-USB/Aux adapter, a Tp-link Tl-mr3020 and any chinese RJ-45 to USB adapter
 

·
Registered
Joined
·
217 Posts
Just to clarify... for the 3GP units (no sim slot)

The connection works like this?

AMI -> USB hub -> USB-RJ45 -> Router -> Cell Phone

--------------´

Is this correct?

So I would need for example the AMI-USB/Aux adapter, a Tp-link Tl-mr3020 and any chinese RJ-45 to USB adapter


I didn't have good luck with USB hubs even when enabling the option in green screen. I went for a USB cable - Male Y to dual Female.

Why do you need aux adapter?

As previously mentioned if you read... No not ANY Chinese adapter you need a Ethernet to USB adapter that utilises one of these axis chipsets AX88772 AX88772A AX88172 I believe any compatible with a Nintendo Wii will work however not 100%. I bought a uGreen one from China.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
Upon installing Google you'll be able to go into navigation settings and Google Earth will be a view option in the drop down box.

If it's not there go into green screen and check if it's installed by choosing 'get info gemmi' if installed then start the application persistent. It's pretty easy soon as you go into 'googleearth'.




Sent from my iPhone using Tapatalk


I just got the cable for vcds, I installed both Chinese and English version of vcds. The English version had a grey out option of 10. And the Chinese version does have a clickable option 10. But I'm not able to find the value in option 10 in Chinese version. I heard from someone that green screen isn't working in newer Audis.

Ps. I have 2016 A6

 
841 - 860 of 973 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top