Audi A5 Forum & Audi S5 Forum banner
1 - 20 of 55 Posts

·
Registered
Joined
·
217 Posts
Managed to get Audi connect and Google Earth working on my 3GP NON SIM at the cost of £43 if any of you in the UK need any tips on how to get a tethered connection from a iPhone to MMI and want Google Earth give me a shout il try help as best I can.

I haven't attempted Online TMC yet so can't say if my car will register for a license.



Please note my car is factory fitted with 3GP with navigation plus, I cannot help with retrofits.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
I tried to PM but don't have enough posts yet. Please could you let me know what you did/got to get this working? Have you managed to get it registered and working with Audi Connect? My model is HN+_EU_AU3G_P0814

Thanks in advance


Audi connect and Google Earth work fine haven't adapted the module yet to even try to register for online traffic license. When I do I will feed back should be next couple days.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
I just realize I have the same situation with you. I have no SIM Slot, but the 3GP MMI, mine is A6 2016 not in Europe, so I would like to have a back up for my regions firmware. And I really want google maps connection with my phone and Audi connect on my A6 using tethered connection from my phone.


When you update firmware make sure you choose Y for GEMMI. This will install Google Earth.

For tether you need a Ethernet to USB adapter that utilises one of these axis chipsets AX88772 AX88772A AX88172 I believe any compatible with a Nintendo Wii will work however not 100%. I bought a uGreen one from China.

You'll need a mobile router that has the ability to connect to a hotspot, I used a TP link mr3020.

I used a good old fashioned USB male to twin female which allowed me to power the router an plug the Ethernet adapter into AMI.

Few configurations in green screen an your done. You'll need VCDS if you want to try attempt to activate a Online TMC license.

If you want to PM any time.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
Hi nyzrox,
First, I would like to ask if I'm able to unhide the Google Earth and Audi Connect in green screen in my region firmware? Like what you said, I'm not sure is it my region's dealer hide it or is it the firmware hasn't include it.
And did you install the mmi UK Region firmware? Am I able to use Audi connect and google earth at different region? Since its using data connection, I can update information constantly using Internet. Thanks for all your help


I had to un hide all the POI stuff which enables the Audi Connect. I will try find where it is as I don't remember off the top of my head, it's in green screen somewhere.
Google Earth is installed off the firmware then you can goto googleearth in green screen and start the application.

I'm not sure which regions it'll work I'm in the UK so I used the appropriate firmware for my region.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
Seems like I'm able to enable Audi connect with green screen. And by installing google earth, will it erase all the offline map which is provided by Audi?

My concern is that I have two languages of my mmi, one is English, one is Chinese. I believe if I upgrade with an EU firmware, I'll lost my languages but with the languages provided by EU firmware.

I would like to have Audi connect and google earth if I'm able to enable it with green screen, not upgrading the firmware.


Sent from my iPad using Tapatalk


GoogleEarth is installed from firmware. Go into green screen goto googleearth an see if it's installed if it isn't you need to install it from the firmware. You can just install gemmi as first time I updated to K0900 I didn't install it as wasn't required. When it was I ran firmware again an set everything to N except Google which I changed to Y.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
So I believe right now I would need to go in green screen and check if there's an option for Audi connect and Google earth.

If not, then I need to update the firmware using EU package (mine mmi is RoW), and while installing, I need to check the option for Google earth.

Is the the right approach?


This is from another forum which is same process I completed.

In the green (hidden) engineering menu under /config set "Install Fair Mode". This will enable the dhcp server and DLinkReplacesPPP via USB. Under /diagnose/coding/internal_modules_1+2 deselect all the "online" choices.

For googleEarth it has to be installed but you can check this in green screen.

I don't know about firmware for you as I say I'm in UK, attempt a firmware update using your region. You don't have to update you can just see what it'll install and if 'GEMMI' is listed then install it an you'll not new European firmware.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts

·
Registered
Joined
·
217 Posts
I've copied the green screen zip file but doesn't appear anything on the screen. But in Media -> Source, it recognizes it is a update medium, then I go to update mmi section, it doesn't allow me to apply the script since it's not a firmware package.

Btw, am I able to deactivate hidden screen with script?


No idea how it works, as stated I used VCDS I had the tool there so was no need for the script.

Again no idea, but wth VCDS you can just change back so green screen isn't active but no point anyway useful thing to have.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
Ok, I've already ordered a VCDS cable.



Btw, do I need to enable some settings in green screen in order to get in red engineering mode?



Mine is 3GP and I tried to get in by holding car and back button


Not as far as I can remember, no green menu isn't required for engineering menu.

Car an Back button should get it up usually will say 'Loading green screen' along those lines.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
Weird, I pressed two buttons more than 20 seconds, nothing shows up. But I'm able to reboot the mmi in five seconds. I'm wondering if my dealer locked some functions up.


Sent from my iPad using Tapatalk


Green screen won't be active if you have Prodution firmware I believe this was the situation for me.

As I say VCDS can activate or running a script but I have no experience with the script.

I've ran scripts before for things like map activation and it was required to wait a good few minutes for the MMI to fully boot.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
I mean the engineering menu, how long should I be holding two buttons to reach the engineering menu?

Ps. I haven't activate green screen


Sent from my iPad using Tapatalk


For red engineering menu start by pressing car then immediately after press's back and hold both buttons for a few seconds. May take a few attempts to get in.

If your thinking todo firmware update I wouldn't without green screen as you'll want to enable user defined mode to be able to manually select of what to upgrade/install.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
Ok, so after I install google earth by user defined mode, I'm able to switch back to normal map?

I wouldn't need to update the whole firmware, but only install google earth by user defined mode


Sent from my iPad using Tapatalk


Upon installing Google you'll be able to go into navigation settings and Google Earth will be a view option in the drop down box.

If it's not there go into green screen and check if it's installed by choosing 'get info gemmi' if installed then start the application persistent. It's pretty easy soon as you go into 'googleearth'.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
For this to work I had to go in green green to /USB and enable 'Hub + iPod/USB Cable support'.

USB male Y splitter to dual female.
UGreen Ethernet USB adapter AX88772A chipset
TP Link mr3020

Here is mine connected up in the car.



First you'll want to set it all up plug into a computer and setup the router in WISP mode and connect it to your tether.

Connect all up in the car.
Green screen again to /config
Install fair mode.

Upon completing rebooted my mmi went back into green screen, checked /USB Ethernet adapter was detected.

Went into /config/console checked I had a IP address.

After this all working.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
Just to clarify... for the 3GP units (no sim slot)

The connection works like this?

AMI -> USB hub -> USB-RJ45 -> Router -> Cell Phone

--------------´

Is this correct?

So I would need for example the AMI-USB/Aux adapter, a Tp-link Tl-mr3020 and any chinese RJ-45 to USB adapter


I didn't have good luck with USB hubs even when enabling the option in green screen. I went for a USB cable - Male Y to dual Female.

Why do you need aux adapter?

As previously mentioned if you read... No not ANY Chinese adapter you need a Ethernet to USB adapter that utilises one of these axis chipsets AX88772 AX88772A AX88172 I believe any compatible with a Nintendo Wii will work however not 100%. I bought a uGreen one from China.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
When I plug in the cable, I have some pop sound from my speaker. But I'm not able to enable the green hidden screen. I asked the vendor and they said it has been locked since 2016 and newer models.


I have no idea if it's locked or not can't help you with that. I've completed on 2012


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
Has anyone had any success with the online POI or adding custom POI using this method? I've just ordered the parts and am interested in getting the POI feature to work.

Thanks.


Haven't managed to get this to work like it does when you have a SIM. As the mmi is only Internet connected when tethered.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
217 Posts
Thanks for the reply. When you are tethered can you link to a my.audi account?


Never tried how do I do this? An I can let you know

I still haven't even adapted the module yet to see if I get online TMC.


Sent from my iPhone using Tapatalk
 
1 - 20 of 55 Posts
Top