Audi A5 Forum & Audi S5 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey everyone this is my first post ever here. Hope you are doing well

Last thursday it was -5 degrees and the MMI was already having trouble starting up. Halfway to work, the MMI completely shuts off and has been stuck ever since.

Both Navigation and Media will say "Initializing, Please Wait" the entirety of the time that the MMI is on. The navigation will load up to maybe 12% before it switches to "Navigation Initializing, Please Wait" and stays stuck like that. I keep hearing what sounds like two marbles clanking into each other behind my CD component. My radio works and the ability to navigate into my phone book or car service works fine, the mmi is starting up perfectly too. But the Navigation and media seem to be completely stuck, all "Settings, Functions" and other corner settings of the screen are greyed out and I'm not able to click on them.

I've searched around and only found 1 thread about this problem that no one's been able to solve. Someone in that thread had a Q5 with the same exact problem, the clanking of what sounds like marbles but everything else worked just fine. This person said they took their car to get inspected for $180, the dealership wasn't even sure what the problem was so they offered to replace the entire MMI for $2,400.

What do you all recommend I do? Everyone tells me this a new phenomenon and I should go straight to the dealership but I feel like I already know what I'm walking into $$$$.

Thanks for your time. Have a good day
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
394 Posts
Sounds to me like the 60 GB HDD inside the MMI main unit has failed. Navigation & media read data from the HDD, while all other MMI functions get their programming from flash memory that's not dependent on the HDD.
I'd start the Green Engineering Menu and look at the HDD diagnostic info in /environment > hdd > smart > viewsmart. Best case you "only" need to replace the HDD from another MMI3GP system (still not really plug-and-play, but better than the alternative); worse case, you need to replace the MMI main unit, which will require a visit to an Audi service center to have component protection removed on the replacement. --g

PS: If you plan on keeping the car for a while longer, replacing with an automotive/industrial SSD is an option (search for "mmi ssd upgrade"), though this still requires a working HDD, since the partition information on the new SSD cannot be created without a QNX run-time environment (and these are very specialized), so a working HDD is need to clone onto the SSD. --g

PPS: Any US MMI 3G+ main unit will do, VAG base part number is 8R1035746 (versions up to 'J'). --g
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
394 Posts
I think the 3G High (HNav) HDD is 40 GB, while the 3G Plus (HN+) HDD is 60 GB (Toshiba MK6050GAC).
And I think the A6/A7/A8 (HN+_R) all get 80 GB HDDs.

This looks like a good source for the 80 GB version currently: TOSHIBA MK8050GAC - 80 GB IDE 4200 rpm 2.5" HDD 683728109783 | eBay

But, again, you'd need a working HDD from which to clone. --g
 
1 - 4 of 4 Posts
Top