Audi A5 Forum & Audi S5 Forum banner

MMI 3G navigation 6.30.1 Europe - currently 2020

89841 Views 419 Replies 72 Participants Last post by  vasilepitaru67
2020 maps version 6.30.1 - PLEASE NOTE - this package is ONLY suitable for 3G and not 3G+/3GP so if your firmware version doesn't match the style indicated in the instructions do not bother downloading this file, as it's been cut down to make the download smaller and so it'll fit on a 32GB SD card without issues.

26.99 GB folder on MEGA

The link above includes an activator file, but if you've successfully updated in the last couple of years you shouldn't need it. Note that the activator needs to go on a seperate SD card, and shouldn't be copied with the map files.

For facelift cars with 3G+/3GP see other thread for correct links - don't muddle them up as it doesn't go well.....

Update instruction guide below - this one is a better layout than the one I produced a couple of years ago, and covers firmware updating etc


PLEASE NOTE - THESE ARE FOR EUROPE, NOT ROW OR NA and I cannot help with questions about where to find them.

I did not need to re-activate, having done so for 2018 maps. I did still get the SVM error in VCDS, which doesn't stop it working if you leave it/don't have VCDS.

I recommend using JDownloader to grab the links and WinRAR for extracting the archives when finished downloading. If you hit the download limit from Mega and don't want to pay for premium downloads I can recommend using the Opera browser, which has a built in VPN tool so all you need to do is switch location and it will allow you to continue downloading. You do lose the option to use JDownloader if you go that route.

These files are from a variety of sources, so credit due to all those who compile and make available :grin2:

If you don't have up to date firmware, links in the thread below:

MMI 3G navigation 6.24.2 Europe and firmware updates -...


  • Like
  • Helpful
Reactions: 5
1 - 3 of 420 Posts
I'm having trouble activating my maps.
Updated to HNav 257 and maps 6.30.1, however the activator does not boot for some reason. I have tried 3 different SD cards and the activator uninstaller booted like a charm. Any ideas?
I seem to have the same problem.

Updated from stock firmware (P0022) to latest (K0257_6) before updating the map-database, but now the Nav says "Navigation data is blocked" and the activator refuses to boot...
  • Like
Reactions: 1
Okay, I finally got it to work.
To be honest, I don't know what made it work this time, but this is what I did:

1. Script files should go directly in the root of the SD-card:

I tried sometimes to have the wrapping folder around them, but that didn't work at all.

2. The car was started without the card in it's slot. I let the MMI boot up while I drove to work (about 20 mins) before inserting it.

3. The car was stationary when the SD-card was inserted.

I'm not sure if the car being stationary was what made it work, but it didn't seem to boot at all when inserting the card while driving.

Thanks for the map and detailed firmware update procedure, @Adrian E!
I used the magnet link for downloading and am currently seeding.
See less See more
  • Like
Reactions: 1
I may have responded in the wrong thread, but here:

Two things to note about my successful activation:

1. I didn't use the Engineering menu to install the activator. It simply started itself once I inserted it into the card reader.
2. I thought these were the same, but the activator I used may have been the one from this thread

As noted, I thought these were the same files.
I loaded them into two different SD-cards, in case one of them didn't work, which the first one didn't.

Once I put the second card into the SD-card reader in my car, which at that point had been running for 10-15 minutes, I didn't open the Engineering menu.
What happened was simply that a dialog showed up, stating "Press any button to <something>".

When I then pressed the main button, the dialog disappeared for a bit, before saying "Installation complete" or something along those lines.
Upon starting the car again later that day, the maps were activated and worked flawlessly.

@yanioaioan, @edoedin, @brucehill
See less See more
  • Like
Reactions: 1
1 - 3 of 420 Posts