Audi A5 Forum & Audi S5 Forum banner
Status
Not open for further replies.
1 - 20 of 54 Posts

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #1 · (Edited)
Links to the latest versions of firmware and map update (with activator)

Firmware:
Linkcrypt.ws // Key-Captcha

Mega firmware:
https://mega.nz/#F!BdV1FADa!M35If02OSTILODgcBLVvvw

The firmware package currently contains versions:

0031_3
0206_3
0253
0257_5

There is 0257_6 available, and the package will be updated to this version (replacing 0257_5) after I've got the map uploaded. _6 is not necessary to run the maps and I gather it is only a small update compared to _5 if you're already there. There is unlikely to be any further firmware update for 3G from Audi.

2016 maps version 6.22.4

link removed

Update instruction guide attached (pdf) from 2015 - nothing changes apart from the map version information

PLEASE NOTE - THESE ARE FOR EUROPE, NOT ROW OR NA

I recommend using JDownloader to grab the links and WinRAR for extracting the archives when finished downloading.
 

Attachments

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #6 ·
I've updated the OP to include the firmware levels included - this will be updated as mentioned, once the map file is done.

This thread will only cover 3G - 3GP I have no knowledge of at all, since I don't have it. I'm happy if there's discussion of options and if anyone has access to the firmware, instructions for updating, and details of reasonably priced/free activation for 2016 versions for 3GP then crack on, either in this thread or start a new one and I'll sticky it :)

Similarly 3G Basic/BNav let's keep separate as it gets confusing!
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #11 ·

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #17 ·
The reason for recommending deleting the partition is that many pre-2010 vehicles left the factory with any inadequately sized nav partition, so after updating the firmware it resets the partition size to make sure you don't get the failed install message. It shouldn't be necessary to do it after the firmware has been updated to the current level, so maybe it's something I need to revisit in the guide.

I think I caveat it a bit in the guide, but I did delete as a belt and braces approach and didn't suffer any problems. Also figured it might get around the need on earlier cars to go into the green menu and change all the values by 1 to get around the 'invalid dataset' message, although not tried it on an older car to see if that actually works! Original 2009 firmware versions would be ideal guinea pigs.

2 of 8 parts have uploaded so far (they're 2.5GB each) but I left it running this morning and either it's taking ages or the upload has stopped and I won't know till I get home.....it shouldn't take 'that' long to upload, given the hassle of doing the install. I'd wait a day or two rather than running the update twice in quick succession
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #18 ·
3 of 8 parts now up - it's uploading at about 380KB/s......

Will leave PC on until it's done
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #21 ·
According my app the files have finished uploading - need to organise them and will update with a link :)

still on my way home from work at the moment :/
 
  • Like
Reactions: dsa

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #22 ·
Link now added to OP :grin2:
 
  • Like
Reactions: Matthew Borrett

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #29 ·
Have you got the folder structure right on the SD card, or have you used a Mac to copy the files over?

Can't think of any other potential reasons it can't read the metainfo file from the top level of the card....
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #42 ·
Ask them how much they'd charge just to activate it. Installation isn't a problem, it's getting it to work after that's the challenge! Yours is 3G+ so later than what we're discussing in this thread, although map file is the same.
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #46 ·
Hello,

I'm trying to update my maps to 2016. I get AUDI_MMI3G_ECE "?" rather than a "Y" after the metainfo is read. Does anyone have a clue what can be causing this error?

Thanks.
Files aren't right on the SD card - either from downloading/unpacking with a Mac, dodgy download or problems writing to the SD card
 
  • Like
Reactions: Quasimotor

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #50 ·
could someone help me with the update please.

I have a A5 from 05.2012 with 3GP+ HDD and without sim. My version is P0530 (see also the attached picture). What must I do to update my MMI?

Thanks for your time
Your version isn't covered by this thread - you will most likely have to pay someone to activate it, although firmware (not the ones in this thread) are available and you can use the map file itself from this thread.
 
  • Like
Reactions: rajeev

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #53 ·
Hi Adrian

Firstly thanks v much for this simple guide.

I just went to kick it off on my 2011 A5 I got last week, and checked my version so I knew where to begin. But my version number seems very different to all those posting here, it doesn't start with "HNav"

Train / Software version: 3G_DAB_K0098
MU Software: 0167
Nav DB: 8R0060884N ECE 5.12.5

So I'm a bit stuck already - as far as I know I have 3G High (Joystick, high res screen, HDD). Do I just kick off from update 0206 (2nd firmware folder)?

Thanks again
That's a weird descriptor for the version! That appears to be original 2011 map files for 3G but by the looks of it yours has required a DAB specific update with its own firmware level

Assuming you have the jukebox function to absolutely 100% confirm this isn't BNav/3G Basic then you should be able to use the files here.

I think you're correct to start with the 2nd level of firmware and go from there :)
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #55 ·
Thanks Adrian, I like to be a bit different...

Is there any way to export / backup this firmware just incase? Or will it either work & be fine or fail and rollback to existing?

Thanks
In all honesty I don't know, but I'm not aware of any method to backup the firmware. Since most of the firmware has never been subject to change I would imagine a full download of the firmware on every module would be quite a task. I'm not a coder but I'd also assume it's not as simple as reading it as installed to be able to put it back?

I would have to add a 'kind of working but displaying odd behaviour' as a 3rd option, but I would expect it to be fine.

You could try reading up on your firmware but I'm 99% sure it was to install a specific DAB fix at customer request. I would expect that fix to have been part of a later firmware release so may not have actually been done to that many vehicles.
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #57 ·
You don't need to update your firmware, but if you want to update it just run the last _6 version. Your firmware level is late enough that it won't mess anything up by doing that :smile2:
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #62 ·
Hi Adrian E
Would you have maps updates 2015 / 2016 for MMI 3G+ PLUS audi a6 S line 2011 new shape my MMI version is HN+R_EU_AU_P0475 of course not for free :) because I try everything and I cant get it the updates,
Could you take a picture of the version ... strange P0475 is A4/A5/Q5/Q7 ... for A6/A7/A8 should be P0485. And do you have sim slot or not?
Cheers.
It's got P so it most likely left the factory at that firmware level - it may well be the earliest available for the A6?

You can use 2016 maps as here and I believe there is an activator available for firmware version 0900 without SIM, but it's not on this site.

Congo may be able to provide more info
 
  • Like
Reactions: congo

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #73 ·
Hello, so I tried to update my firmware and maps but wasn't successful because I got this every time I tried to do it:

"A variant conflict occurred!
Main Unit variant: 9303
Release info variant 9307 9308"

Does anyone know what I could do in this situation?

Thank you.
I just looked back through your old posts - you're in the wrong thread for updating your nav!! You have BNav aka 3G Basic. You need different firmware updates and different map files.

0260 is the latest BNav firmware and map database is 5.22.3
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #117 ·
I would say no point - I noticed a negligible difference in time taken to update by doubling card speed from x45 to x90 (IIRC) and suspect the limiting factor is processor capability and HDD write speed.
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #120 ·
Have I done something wrong?
As above you need to ensure the file structure on the SD card is as below, with no folder levels above this:

 

Attachments

  • Like
Reactions: DavidHunter

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #126 ·
Just to confirm if its the same case as mine:

HNav_EU_K0257_5_D1

Can i just run the last _6 version?
Yes :) - although the maps will install with the firmware level you have as well
 

· Premium Member
Joined
·
1,311 Posts
Discussion Starter · #127 ·
Thank you Adrian for this.

I'm new to Audi MMI and upgrading. I have A5 Sportsback 2009.

This is what I got from the Engineering Menu

Software version:
HNav_EU_Poo22_d1

Nv. database version:
8R0060884E_ECE 5.8.5

I have seen you thread for Nav MAPS 2015, but then I came across this one for 2016.
My question is do I need to update all the firmware from 2015 and then all the others from 2016 (this thread) to be able to install 2016 maps or is it enough to just install firmwares from this thread?


Thank you again.
The firmware updates should be the same files - if you're starting from that old firmware you'll have 4 sets of firmware to run but you can go to 0257_6 without installing 0257_5 first, once you've done the first 3 sets

So:

0031
0206
0253
0257_6
 
  • Like
Reactions: starmo
1 - 20 of 54 Posts
Status
Not open for further replies.
Top