Audi A5 Forum & Audi S5 Forum banner
921 - 940 of 1010 Posts

·
Registered
Joined
·
7 Posts
MMI 3G Basic navigation 5.31.2 and firmware updates - currently 2020/2021

Links to the latest versions of firmware and map update (with activator)

Map & activator:
MMI 3G Basic 5.31.2 Europe 2020/2021 [Link on Mega]

DVD1 East: Germany, Lichtenstein, Austria, Switzerland, Albania, Bosnia- Herzegovina, Bulgaria, Denmark, Estonia, Finland, Greece, Italy, Croatia, Corsica, Kosovo, Latvia, Lithuanian, Macedonia, Moldavia, Montenegro, Norway, Poland, Romania, Russia, San Marino, Sweden, Serbia, Slovakia, Slovenia, Czech Republic, Ukraine, Hungary, Vatican City, Belarus
DVD2 West : Germany, Lichtenstein, Austria, Switzerland, Andorra, Belgium, France, Gibraltar, Great Britain, Ireland, Luxembourg, Monaco, Netherlands, Portugal, Spain

Firmware:
MMI 3G BASIC A4-A5-Q5-A6-Q7 [Link on cloud.mail.ru || Link on Mega]
• 8R0 906 961 AA – BNav_EU_K0031_2_D1 (SVM: 3GBEU031)
• 8R0 906 961 AH – BNav_EU_K0070_2_D1 (SVM: 3GBEU070)
• 8R0 906 961 BD – BNav_EU_K0206_2_D1 (SVM: 3GBEU206)
• 8R0 906 961 DK – BNav_EU_K0257_2_D1 (SVM: 3GBEU257)
• 8R0 906 961 DP – BNav_EU_K0260_1_D1 (SVM: 3GBEU260)

• 8R0 906 961 AL – 3G_DAB_K0098 (SVM: 3GRU0098)
• 8R0 906 961 BC – BTHS_0400

If your firmware version is bellow K0257 then do K0257 followed by K0260. If you are at K0257 do only K0260.

Manual:
3G_BASIC.pdf [Link on cloud.mail.ru || Link on Mega]

Q&A section
Here are some of the questions raised by the forum members about the update process that I might failed to explain in the manual.

Q. Do i need VCDS to do the update?
A. No, you need VCDS only to clear some errors after the update but the MMI will function correctly even if you don’t clear them out.

Q. I have a Bang & Olufsen sound system not a Bose. Does this also mean that i need to exclude it?
A. Yes, better not to update the DSP system.

Q. Currently no updates for North America?
A. Not for now.

Q. I have mmi 3g , version p0XXX can i go straight to k0260?
A. Yes.

Q. 01043 - Control Module; Incorrect Software Version - How can i solve this ?
A. Restart the MMI and remove the key from ignition then put it back in. The error should change from 01043 - Control Module; Incorrect Software Version to 03276 - Please Check Software Version Management.

Q. What are 03276 and 03175, will they affect the MMI in anyway and how can they be avoided?
A. 03276 - Please Check Software Version Management will appear every time when the software is updated w/o VAS connection to the VW/Audi servers.
03175 - Invalid Data Set will appear when updating the map w/o deleting it first. Sometimes this helps to avoid that error.
They will not affect the functionality or the sound characteristics of the MMI.

Q. Is there a way to use used defined mode w/o "Green Menu"?
A. Yes. In file metainfo2.txt in the root folder if you remove the line "MetafileChecksum=XXXXXX" and add
EnableUserDefinedSWDLMode = "true"
skipMetaCRC = "true"
the you will be able to use the user mode w/o the green menu.

Warning - At no stage I take responsibility of your actions or any of my notes that may mislead you. Therefore, and like my all other documents I say “use at your own risk”.

Cheers :wink2:
Can you please help me,
collected a 2010 60 plate Audi A5 on Saturday
What do I need to get the sat nav working?
MMI 3G Basic navigation 5.31.2 and firmware updates - currently 2020/2021

Links to the latest versions of firmware and map update (with activator)

Map & activator:
MMI 3G Basic 5.31.2 Europe 2020/2021 [Link on Mega]

DVD1 East: Germany, Lichtenstein, Austria, Switzerland, Albania, Bosnia- Herzegovina, Bulgaria, Denmark, Estonia, Finland, Greece, Italy, Croatia, Corsica, Kosovo, Latvia, Lithuanian, Macedonia, Moldavia, Montenegro, Norway, Poland, Romania, Russia, San Marino, Sweden, Serbia, Slovakia, Slovenia, Czech Republic, Ukraine, Hungary, Vatican City, Belarus
DVD2 West : Germany, Lichtenstein, Austria, Switzerland, Andorra, Belgium, France, Gibraltar, Great Britain, Ireland, Luxembourg, Monaco, Netherlands, Portugal, Spain

Firmware:
MMI 3G BASIC A4-A5-Q5-A6-Q7 [Link on cloud.mail.ru || Link on Mega]
• 8R0 906 961 AA – BNav_EU_K0031_2_D1 (SVM: 3GBEU031)
• 8R0 906 961 AH – BNav_EU_K0070_2_D1 (SVM: 3GBEU070)
• 8R0 906 961 BD – BNav_EU_K0206_2_D1 (SVM: 3GBEU206)
• 8R0 906 961 DK – BNav_EU_K0257_2_D1 (SVM: 3GBEU257)
• 8R0 906 961 DP – BNav_EU_K0260_1_D1 (SVM: 3GBEU260)

• 8R0 906 961 AL – 3G_DAB_K0098 (SVM: 3GRU0098)
• 8R0 906 961 BC – BTHS_0400

If your firmware version is bellow K0257 then do K0257 followed by K0260. If you are at K0257 do only K0260.

Manual:
3G_BASIC.pdf [Link on cloud.mail.ru || Link on Mega]

Q&A section
Here are some of the questions raised by the forum members about the update process that I might failed to explain in the manual.

Q. Do i need VCDS to do the update?
A. No, you need VCDS only to clear some errors after the update but the MMI will function correctly even if you don’t clear them out.

Q. I have a Bang & Olufsen sound system not a Bose. Does this also mean that i need to exclude it?
A. Yes, better not to update the DSP system.

Q. Currently no updates for North America?
A. Not for now.

Q. I have mmi 3g , version p0XXX can i go straight to k0260?
A. Yes.

Q. 01043 - Control Module; Incorrect Software Version - How can i solve this ?
A. Restart the MMI and remove the key from ignition then put it back in. The error should change from 01043 - Control Module; Incorrect Software Version to 03276 - Please Check Software Version Management.

Q. What are 03276 and 03175, will they affect the MMI in anyway and how can they be avoided?
A. 03276 - Please Check Software Version Management will appear every time when the software is updated w/o VAS connection to the VW/Audi servers.
03175 - Invalid Data Set will appear when updating the map w/o deleting it first. Sometimes this helps to avoid that error.
They will not affect the functionality or the sound characteristics of the MMI.

Q. Is there a way to use used defined mode w/o "Green Menu"?
A. Yes. In file metainfo2.txt in the root folder if you remove the line "MetafileChecksum=XXXXXX" and add
EnableUserDefinedSWDLMode = "true"
skipMetaCRC = "true"
the you will be able to use the user mode w/o the green menu.

Warning - At no stage I take responsibility of your actions or any of my notes that may mislead you. Therefore, and like my all other documents I say “use at your own risk”.

Cheers :wink2:
Hi

can you help me please,

I collected a 2010 60reg Audi A5 on Saturday,
what do I need to make the sat nav work? A dvd or a sd card?
Any help is appreciated
181206
181207
 

·
Registered
Joined
·
7 Posts
Confirmation?

Hi Congo,
I've just found this thread while searching for firmware updates for my A6 Avant C6, which has MMI 3G Basic (Low).
All the indications here suggest that the firmware files you have posted are the same for my system as for the A5 but before I go ahead and start the update process, could you please offer any reassurance that I am correct in this assumption?
My biggest fear is that I'll brick the MMI!
Thanks in advance.

This is my system:
Hi,

sorry does your sat nav use a dvd or sd, I collected a 2010 A5 on Saturday and the car is missing the dvd or sd card
181216
181217
 

·
Registered
Joined
·
30 Posts
After many hours of trying to get rid of the checking medium message using all the techniques given here I was about to give up.
But I thought I'd give it another try.
So I done an emergency update on the green menu using the current K0260 firmware.
Then I put the sd card with the 2020/21 map in sd1 slot, again it said checking medium.
This time I went into the red engineering menu and saw the map software shown on the screen and clicked and updated it.
After exiting and rebooting, the map started and I didn't need a script to activate.
I found The instructions are similar to what I done in the write up on this Web page so follow them and you should be OK.
https://www.motor-talk.de/forum/aktion/Attachment.html?attachmentId=7745
.
It may be possible to do this without doing the emergency update. so maybe try it without the emergency update and just go into the red menu and update first and see if it solves the checking medium problem. Hope this sorts out your problem.
 

·
Registered
Joined
·
5 Posts
Hi,
I still have the problem updateing my Audi A5 Train Version K0070 to K0260.
I prepared SD cards as described by congo. I followed his instructions.

My problem is when I choose after all necessary steps "Start update" I the get the screen with "Start" and "Abort", I pressed Start and waited but nothing happened ? No Reboot, the next screen "Update progress" did not came, No download...
I assume the process is not starting
The only chance was to abort the update. The logging menu showed the tried update, but with NOK.
Did I make something wrong or forgot something? Any workaround? Please help me :)
 

·
Administrator
Joined
·
4,615 Posts
Did I make something wrong or forgot something? Any workaround? Please help me :)
what is the model-year of yr A5 ?
did you use a full size SD-card or did you use a micro-SD with adapter ?
what is the size of the SD-card ?
how was the SD-card formatted ?
 

·
Registered
Joined
·
6 Posts
Audi A4 B8 MMI 3G Basic
I have a micro-sd but today i will buy a normal sd card
FAT32 card format files are fine on the card
Is it the fault of the SD card ?? Because I read that it may be the fault that the original DVD map was installed and now you need to remove the activator and FSC ???
 
921 - 940 of 1010 Posts
Top