Audi A5 Forum & Audi S5 Forum banner

MMI 3G+/3GP navigation 6.36.0 and firmware updates - currently 2023 Europe

460699 Views 1730 Replies 351 Participants Last post by  DrGER
MMI 3G+/3GP navigation 6.36.0 and firmware updates - currently 2023 Europe

Its time for a new thread and i hope this one will be kept clean :)
Here is a link to the old one, please check there before asking questions that might have already been answered in the past.

Links to the latest versions of firmware and map update (with activator)

Maps & activator:

6.36.0 2023 MMI 3G High/Plus Europe [Link on Mega (use 7z/7zip to open the files)]

Rest of World
5.13.4 2021 MMI 3G High/Plus ROW - ANZ,SA,ME,HN,SM ... here!

6.20.1 2019/2020 MMI 3G ... here! If it asks for password then use this one -> 8R0060884GJ

Activator [Link on Mega]

Audi A1 [Link on Mega]
8R0 906 961 EC – HN+_EU_AU210_K0900 (A1) SVM: 3GPEU900A1

Audi A4-A5-Q5-Q7
HN+_EU_AU3G_K_0900 - Stock firmware
HN+_EU_AU3G_K_0942 - Stock firmware
HN+_EU_AU3G_K_0900 Modified firmware - User Defined Mode / No Sound systems
HN+_EU_AU3G_K_0942 Modified firmware - User Defined Mode / No Sound systems

Audi Q3-A6-A7-A8
HN+R_EU_AU_K0900 - Stock firmware
HN+R_EU_AU_K0942 - Stock firmware
HN+R_EU_AU_P1001 - Stock firmware
HN+R_EU_AU_K0900 Modified firmware - User Defined Mode / No Sound systems
HN+R_EU_AU_K0942 Modified firmware - User Defined Mode / No Sound systems

3G_3GP.pdf [Link on Mega || Spanish translation thanks to homarc || 2017 MAP Update thanks to homarc]
How to user 64GB SD card [Link on Mega]

These are the required files and folders for Map 6.33.1 with 32GB SD card. Thanks to @JulianHicks for creating the lists.
See "3GP_Filelist.txt" (3GP) and "3GH_Filelist.txt" (3G High) attachments in this post.

You might need GEM (Green engineering menu) activated and use User Defined Mode and manually select all that is under AUDI_MMI3G_ECE if it's not selected.

Warning - FW update K0900 is removing the "Emergency Update" option from the "Green Menu". There is a way that this can be fixed.

• Emergency menu activation on K0900 firmware. [ Only for A5OC ]
• To enable the Green Menu you could use VCDS, VAS or the following script [ Green menu activation ]
• 03623 [ 03623 Remove ]
  1. Unzip it on the SD card.
  2. Put the sd card in the MMI.
  3. When prompted press the center knob.
  4. After the script is done you will see confirmation screen.
  5. Remove the SD card and reboot MMI

Do not use MAC to unpack and/or copy the files to the SD card.

The problem:
I've tried to update my firmware (MMI 3G+) to K0767 and got the following error:

GEMMI_nav:0 error code 141
I could only access "Retry" choice (but update kept blocking at 5% with the same error) or "Back" button that was useless
Unable to do anything else, even the Reset procedure didn't work!

Root cause:
This is a file corruption error, the MMI didn't like what it found on the SD card.
Because I'm a stupid software engineer who thinks he knows best, I didn't trust the forums and copied the files from my mac onto the SD card (using command line to clean-up the .Trashes/ and alike folders)
So this is the lesson: DO NOT COPY FROM A MAC
Sub-lesson: better learn from other's mistakes than redo the experience...

As stated previously, even a MMI reset procedure didn't allow me to get out of the error.
So I went to my neighbour's Windows PC, reformatted the SD card and extracted the RAR archive onto it.
Back to the car, update went fine and completed successfully after 30 minutes

Hope this experience will help some fellow here...
LESSONS LEARNED - NEVER USE MAC OS (or Unix, Linux based OS) for unpack and copy map or firmware data into SD card. Also always format SD card in Windows OS. USE ONLY WINDOWS FOR UNPACK/COPY!!!

I had to upgrade Firmware as well. I could not load map data even they were copied in windows. It means that also Firmware was corrupted.
I found cca 10 000 hidden files on Firmware SD card. Dangerous is that Firmware seemed to be OK all the time but it was not and I could destroy whole MMI
(Imagine that FPGA or EEPROM is burned with some hidden apple .bin file....).
Q&A section
Here are some of the questions raised by the forum members about the update process that I might failed to explain in the manual.

Q. Do i need VCDS to do the update?
A. No, you need VCDS only to clear some errors after the update but the MMI will function correctly even if you don’t clear them out.

Q. I have a Bang & Olufsen sound system not a Bose. Does this also mean that i need to exclude it?
A. Yes, better not to update the DSP system.

Q. Currently no updates for North America?
A. Not for now.

Q. I have mmi 3gp , version p0XXX can i go straight to k0900?
A. Yes.

Q. Have found the activation script and it includes "2380_00040009.fsc". This should be changed according to manual Page 31 to the MAC address specifically to my MMI or should I continue to use the "2380_00040009.fsc" as stated in the manual page 18.
A. Leave the filename as it is now.

Q. The 2380_00040009.fsc file contains a VIN number. Should that be changed to my VIN number?
A. No, do not attempt the edit the fsc file.

Q. Will my VIN be visible and correct in the MMI
A. Yes.

Q. Only thing is that my Google Maps option is greyed out... any hints?
A. Reinstall the GEMMI_nav component from the K0900.

Q. 01043 - Control Module; Incorrect Software Version - How can i solve this ?
A. Restart the MMI and remove the key from ignition then put it back in. The error should change from 01043 - Control Module; Incorrect Software Version to 03276 - Please Check Software Version Management.

Q. What does the new firmware bring in terms of added functionality?
A. Not much, apart from K0770/K0767 fixing the issues with the SIM data connection and Bluetooth usage at the same time.

Q. What are 03276 and 03175, will they affect the MMI in anyway and how can they be avoided?
A. 03276 - Please Check Software Version Management will appear every time when the software is updated w/o VAS connection to the VW/Audi servers.
03175 - Invalid Data Set will appear when updating the map w/o deleting it first. Sometimes this helps to avoid that error.
They will not affect the functionality or the sound characteristics of the MMI.

Q. Is there a way to use used defined mode w/o "Green Menu"?
A. Yes. In file metainfo2.txt in the root folder if you remove the line "MetafileChecksum=XXXXXX" and add
EnableUserDefinedSWDLMode = "true"
skipMetaCRC = "true"
the you will be able to use the user mode w/o the green menu.

Warning - At no stage I take responsibility of your actions or any of my notes that may mislead you. Therefore, and like my all other documents I say “use at your own risk”.


See less See more
  • Like
Reactions: 5
1 - 10 of 1731 Posts

If You want to copy the files for 3GP, you need to delete the following folders to fit to the 32GB SD card (Only LIT1-3 is not enough!).

  • CTY
  • CTY2
  • CTY3
  • LIT
  • LIT2
  • LIT3

Hope it helps, for me it worked!
See less See more
  • Like
Reactions: 2
Does this map work on A4 B8 2011 MMI 3G High with firmware "0257_6" (not updated yet)
or is this 2020 map best for now?
You have 3G High system.
Do NOT delete the CTY folder,need that folder.

Need to delete LIT3GP 1- 5 .
  • Helpful
Reactions: 1
what I am missing with deleting cty?
If you have have 3GP you don't need that folder.
Will not miss anything.
I know the topic is about 3GP/3G+, but from the content of the post I assume, that these maps are compatible with 3G High as well, quoting some parts of the post:


I have latest (0257_6) firmware for 3G High and installed these maps. Installation run smoothly, no problems here. However none of the activators, found on this and various other (3G High related) topics works. I tried Vlasoff, Keldo, Darkdll but none of them worked. FSC based, that are run from Engineering menu, execute, but nothing happens after restart, the rest, that should work on any screen, after everything has booted, do nothing, I see no confirmation screen, whatsoever.
I also tried several SD cards - 1GB, 16GB, 64GB, all formatted as FAT32. I still get "Navigation data blocked" kind of message.
As I browse the forum, a lot of people are in similar situation and I failed to find working solution, so I any help will be greatly appreciated. Thank you!
For MMI 3GH 6.32.1 if you can not find any activator, download the 6.30.1 map update your system, it has activator (I have used what you can find in the link).
Than delete the 6.30.1 map, and install the new 6.32.1 than you will not need to activate.
You can try this.
1.13 MB file on MEGA
Hello fans!

I successfully updated my MMI 3GP to the latest maps 6.32.1 - using user defined mode - everything works on my MMI and I am able to see the map when I open the navigation application. (before the update I deleted the NAVdatabase and partition from the Green Menu). But for some reason the GPS is not active, I mean the it is not showing my actual position on the map and the GPS maps are not "moving" when I am changing location/driving, instead it show my last stored location where I was before the update. In addition to this issue, I can enter a new target address and also the app says that "my route has been calculated" but nothing appears on the map - no blue line to follow, etc.... basically nothing happens. I have a feeling that the NAvigation app does not read the data form GPS receiver.

I tried the activator from Keldo, which tells me that it is already installed.

I can see in the green menu that the GPS receiver works, if I am moving/driving the '"textual" coordinates (in the Green Menu /nav/ submenu) are changing... so the GPS receiver is not broken. Still maybe the activation was not successfull?

My Firmware is HN+R_EU_AU_K0942 Stock firmware.

Is there any tips/hints? what can I do? Shall I try to uninstall the activator? or any other idea? is there and activator uninstaller script available somewhere?

Thanks in advance.

Hi Peti,

If you only update map database you don't need any activation.
How many satellites can the car see, in the green menu?

After map update, my location was at the Atlantic Ocean, and after 100m drive it showed my position.
It was not so accurate, sometimes I was driving on a parallel road, but after a reboot, everything worked fine.

Kind regards,

See less See more
Guys im confused on what folders i need to delete to fit the files on a 32gb card, on previous updates ive only ever deleted LIT1,2,3 but in the 2021 folder there is now a LIT4 which i also deleted but still not enough space to copy the files too, there is also talk of deleting CTG but some say no delete LIT3 GP 1 to 5??

Can someone confirm exactly which files need to be deleted. Many thanks.


Than it will fit.
Here are the FOLDERS what MMI 3G+ system needs for the update:


That is why you can delete LIT1-4, CTY... what you can not find in that list!
See less See more
  • Like
Reactions: 1
HI all,

I want to update, my maps only.
Before I updated my firmware and my maps and activated, i have actually:

View attachment 180235

I have any questions i read forum but I have some questions If only want to update MAPS, i no need to erase any think? or I need to erase database nav and partitiion? i think no erase needed because the actual maps has ben activated

If i no need to erase anythink I only follow these manual not?
Only need acces to green menu an activate "user defined mode" and run update and restart and finish? or need activated after update?

Thanks a lot!

1. Need to activate the green menu
2. (In green menu) Delete the NAV database, (no need to delete particion)
3. Install map
4. No need to reactivate the map.

Kind regards,

So I first activate green menu an delete nav database.
Then restart and in green menu and select use define mode and update mapa not=

1 - 10 of 1731 Posts