Audi A5 Forum & Audi S5 Forum banner
1 - 20 of 185 Posts

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
...
and for anyone looking for the NAR map here's a magnet for the 2019-20 6.20.1 NAR Map - 8R0051884GJ / 8R0060881GJ

Code:
magnet:?xt=urn:btih:F9C2FA89021D6502E103A559EA5AFB046B8D6376&dn=NAR%206.20.1&key=8F593C5C4A12C3EEC276B2B96212868209764B9ADAE6E89A2282556AE522C932&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80%2fannounce&tr=udp%3a%2f%2ftracker.opentrackr.org%3a1337%2fannounce&tr=http%3a%2f%2ftracker2.wasabii.com.tw%3a6969%2fannounce&tr=udp%3a%2f%2ftracker.sktorrent.net%3a6969%2fannounce&tr=http%3a%2f%2fwww.wareztorrent.com%3a80%2fannounce&tr=udp%3a%2f%2fbt.xxx-tracker.com%3a2710%2fannounce&tr=udp%3a%2f%2ftracker.eddie4.nl%3a6969%2fannounce&tr=udp%3a%2f%2ftracker.grepler.com%3a6969%2fannounce&tr=udp%3a%2f%2ftracker.mg64.net%3a2710%2fannounce&tr=udp%3a%2f%2fwambo.club%3a1337%2fannounce&tr=udp%3a%2f%2ftracker.dutchtracking.com%3a6969%2fannounce
Albert
After 24+ hours, my torrent client finished downloading a file named "42151f40aa07f154486b", size 22,540,359,965 bytes (md5sum cdc7b8a73fccef11238887cfc6ca5170), using the magnet for the 8R0051884GJ NAR 6.20.1 update, above. Is this correct? On my Solaris 11 x64 server and Linux desktop, "file 42151f40aa07f154486b" returns "data". Not sure how to extract the nav update from this big cryptic file. 7z, rar, & zip don't recognize it. Any suggestions?

Update: Torrent corrected & updated on 19 Apr by OP.
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
After updating maps (and possible activation) run the firmware update again, somehow the map update is messing up Google Earth. After running the firmware update, the Google Earth is working again.
If you choose to delete the nav parition using the GEM prior to running the nav data update, the GEMMI software is also removed (since it is installed on the MMI /nav partition). Thus, if you have a 3G+ system and working 3G data connection and want to use the Google Earth satellite image overlay (while AT&T provisions 3G data and Google makes GE available to us) you can either (1) avoid deleting the nav partition (if you don't need to), or (2) re-install the GEMMI package, only, from the latest firmware, as needed.
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
Ive read through the posts but i dont understand what this means:

Q. I have a Bang & Olufsen sound system not a Bose. Does this also mean that i need to exclude it?
A. Yes, better not to update the DSP system.


What does this mean? That i should use the stock firmware and not the modified version with the green menu enabled?
Yes i have the B&O system in my car.
This means that you should update the MMI firmware using the "User defined" method so that you can choose the devices that get updated individually. The "modified" firmware version enables the Green Engineering Menu for those who don't have access to an OBDII tool that can enable the GEM through adaptation (e.g., VCDS, OBDeleven, Carista, etc.). Depending on your car, this might not even be necessary (e.g., update to the latest firmware for our 2014 A4 MMI 3G+ for US region didn't update any DSP devices, so the standard method was sufficient when we did the firmware update in 2018).
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
Need some help please: I successfully upgraded my firmware but had issues with the NAV update. During the NAV update, I received an error 141 on database LIT3GP:0 . I restarted the system and reinstalled the files back on my SDcard. When I went back to update the NAV, the update is greyed out. The system can see the update and loads up the update but when I scroll all the way to the bottom of the menu to update, it's greyed out. I deleted the NAV DB using the green screen, but it's still greyed out. How do I force an update? what else can I delete to enable "update"?

Thank you!
Did you enable User-Defined Software Update in the Green Menu ? You may need to select all the parts manually to (re)install. Unless your MMI hard drive is failing, software update errors are due generally to faulty/low quality SD cards.
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
I'm trying the user-defined install now. Hopefully, I selected the correct packages. Is there a site that explains which packages you require for your system? 2014 Audi S7 3G+

Before I started the user-defined, I deleted the NAV database. The update was still greyed out, so I'm attempting the User-defined.

I used this config below but some menu items are not listed.

Enabled user-defined mode:
Go to the menu AUDI_MMI3G_ECE ->in each subfolder set the check box so that in front of all sub-feet Y
for US and other will be similar AUDI_MM3G_NAR. (selected all options)
Please also make sure that:
Mapstyles,
Navipersistence,
TMCConfig
---- are also selected to update MMI 3G Maps updates
Select all options to be “Y”
Manually select the entire item (without bootloader)
In the MMI section AUDI_MMI3G_XXX
XXX – depends on region, can be:
NAR for USA / Canada & Mexico
All NAR MMI3GP should require the same packages. I have this documented for our 2014 A4 MMI3GP system HERE; you might find it a useful reference. BTW, which NAR nav update are you using ? I have info for NAR 6.22.1 (2020/2021) HERE.
 
  • Like
Reactions: JohnS4

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
The software version is HN+R_US_AU_K0942_3 and NAR is 6.19.1

It just finished updating using the User-defined method successfully! I started the system up and the NAV is working (the little testing I did) Thank you for the link to the newer NAR! I'm downloading it now. Will the newer NAR need activation? All your documents are helpful as well. thanks for posting the links. More reading to do...
You're welcome.

My (and others) experience with nav database updates has been that "activation" is required only when the MMI software is updated prior to the nav database update -- that is, if your MMI software is current & doesn't get updated (not likely for this generation of MMI systems), subsequent nav database updates will not require "activation".

I haven't studied the requirements for HN+R MMI systems; do you still get 3G data and the Google Earth image overly? I ask because the Google Earth software is stored on the NAV partition, and is erased when the nav database is deleted using the Green Engineering Menu. --g
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
If you were getting GE overlay imagery before you updated the nav database, then you'll need to re-install the GEMMI package (only) from the HN+R_US_AU_K0942_3 software update (if you have access to it). But you just said that you updated the nav database because GE isn't working on your MMI3GP system, so that's not likely to help you.

For the record, Google Earth provides a satellite image overlay service to our base nav database that's stored on the MMI hard disk drive -- it definitely is not Google Maps.

In our case, GE overlay images stopped working last year mid-December due the announced sunset of the service. In February a clever fellow in Bulgaria figured out a way to make GE overlay imagery work again by patching the GEMMI QNX binary and passing the authenticated satellite image data through one of his servers (see his post HERE). Then, in late March, someone at Google turned the GE image service back on for Audi legacy clients without any warning or fanfare (see, e.g., my post HERE), and it's been working (mostly) since then. Of course, the bigger problem for all of us with MMI3GP systems will come when AT&T turns of their 3G network early next year. Oh well, first-world problems.
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
Glad to help.

Re Google Project FI, my understanding is that it uses the T-Mobile network, which hasn't had a 3G service in the US in years (hence the reason Audi switched from T-Mobile to AT&T for mobile data around 2015). What kind of download speed do you see from WiFi device connected to the car's HotSpot ? T-Mobile 2G may be adequate for Audi Connect destination queries, and some web browsing, but not so much for fetching GE images in real time. We use an old (legacy) Freedompop SIM that gets data from the AT&T 3G network. I started a thread about our experience with that over HERE. Unfortunately, Freedompop stopped offering that SIM/plan last fall. --g
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
That's interesting about your MMI3GP data speeds with your Google FI SIM, definitely 3G.

I'm curious about what data service the system is connected to; on our A4, TEL > Settings > Data Connection > Online status overview tells us "AT&T" with the legacy Freedompop SIM.

Re Google Earth: when was the last time the image overlay service worked in your S7 ? GE worked great in our A4 last week (haven't had it out of the garage since, though). I found the K0942_3 update last night, so I can compare the GEMMI package to our (working) K0942_6 package. --g
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
As best I can tell, the GEMMI package on our HN+_US_AU3G_K0942_6 (8R0906961FE) and your HN+R_US_AU_K0942_3 (8R0906961ES) are identical (exact same files), so not sure why yours doesn't start while ours does (at least until the last time I used it).

Other C7 platform owners report the GE overlay working for them earlier this year HERE.

Re updating the MMI (software or database): my experience has been that keyfob in the dash holder (ignition not on), MMI on from the center console control, and in the Red Engineering Menu is sufficient to run updates (with a battery maintainer/charger connected, of course); having the keyfob in the dash holder likely has no affect here, as Audi doesn't mention it in TSB 2028141. It appears that being in the Red Engineering Menu prevents the normal MMI system power-off timer from shutting the system down during an update. HTH --g
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
Before I update the firmware in my A5 2012 with Bang & Olufsen, I just wanted to check first

Media version
HN+_EU_AU3G_P0513
Nav.database Version
8R0060884AH ECE 5.13.8

I download the stock firmware version and inside there's a folder called BO_Q7

After enableing User Defined Mode in the Green Menu

I proceed with the firmware upgrade and selected User Defined but notice that NO folder referring to BO is available to uncheck

Is it safe to continue with the upgrade?
I'd say "yes" -- we had the same situation with our NAR '14 A4q with B & O sound. I believe the BO_Q7 package is intended for the Q7 platform, specifically.
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
  • Like
Reactions: Sbbarra

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
  • Like
Reactions: Sbbarra

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
Hi DrGer; your 'experience' regarding [no need for] Activation with no prior MMI update, is an interesting comment that I've not seen elsewhere. It's a logical explanation though as one presumes the logic is built into the MMI code rather than the map data. [If the activation 'validates' the map by updating MMI code, it's reasonable that a replacement set of raw MMI coide will 'lose' the previous validation].

I'm considering a map update on my UK A8, which had the latest [K0942] MMI code installed together with a new map update and activation, courtesy of Audi dealer when I purchased it in 2018, but the map data is obviously now out of date.

So I presume a map update to EUR 2020/2021 will mean no need to acquire and run any activation scripts?

Julian

BTW; I read your extensive document on updating your NAR system. The most professional document I've seen in a long time ...
Your presumption should be correct: if both MMI software & navigation data were updated from the original production versions, we assume "activation" to the current nav data was performed already, and further navigation data updates will not require "(re)activation". Inspection of the "activation pack" SD card shows that it includes only the encrypted shell script, which is reproduced, decrypted, in my update document. You'll note that the script is generic & makes no specific reference to the VIN of the car being "activated". I haven't yet determined exactly which QNX process "blocks" access to the updated nav data (after the MMI software is updated) & why; if someone here can offer an insight to this, I'd be interested in knowing what "blocks" nav data access & how the script changes fix (i.e., unblock) this access. --g
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
HI everyone, I have A6 C7 2012, and this is version installed:
View attachment 181370

What steps do I have to follow to update my maps?
Thank you :)
This thread is for MMI 3GP/3G+ EU systems (i.e., HN+R_EU_AU_Pxxxx); see the first message of the thread. The MMI hardware in your A6 uses different software/nav data. Look for the software update HERE. Sorry, can't offer any pointers to new navigation/map data for your platform. --g
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
ok gents, so I will specify my issue.
I've got Q5 from Canada - now car is in Europe - I want to update navi to EU (maps) and if possible change language to polish (menu) and another one - change the frequesny of radio.
I'm beginner so I even don't know what tools can be used - SD card? I heard something about "green screen" activation - no idea how to folks.

thanks any support/links
The basic procedure is described HERE. Before you start, you'll want the latest MMI software update for EU region (see the first post of this long thread), followed by the navigation update for the same (EU) region. If MENU+CAR doesn't start the Green Engineering Menu, you'll need a method to enable it (VCDS, Carista, OBDeleven, or SD card script). Be very careful, or you may render your MMI system inoperable. --g
 
  • Like
Reactions: jsz77

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
ok gents, so I will specify my issue.
I've got Q5 from Canada - now car is in Europe - I want to update navi to EU (maps) and if possible change language to polish (menu) and another one - change the frequesny of radio.
I'm beginner so I even don't know what tools can be used - SD card? I heard something about "green screen" activation - no idea how to folks.

thanks any support/links
I took another look at this and it appears that changing the MMI language from US English to Polish is more difficult than the first link suggests -- see HERE and HERE. They tell us that a US region MMI3GP system is programmed for only 3 languages: US English (en_US), US Spanish (es_US), and Canadian French (fr_CA).

But this post HERE suggests that someone might have done this successfully without reprogramming the EEPROM for EU languages (and in the first post of the thread, the OP writes "Already flashed EEPROM in unit". I don't know. I haven't seen anyone else report success with this method (i.e., without reprogramming the MMI EEPROM chip).

I think you need to do more research before trying to do this. --g
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
A novice question,I’ve already firmware updated to K0942. Can I update the maps without deleting the previous database so I don’t have to activate again. I’ve old maps 5.13.8! Is this possible??
Our experience is that doing the firmware update is what triggers the need for (re)activation following the next navigation database update. But look at the thread (e.g., post 225, above). Now that you're at K0942, you'll only need to "activate" following your next navigation update. BTW, deleting the previous database in the Green Menu doesn't affect (re)activation, or is even necessary if you're updating the same region (so, if you already have EU nav data and are updating with EU nav data, no need to delete the nav partition/data).
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
443 Posts
any idea - vcds + key which allow to turn on green menu... please
If you have VCDS, activating the Green Engineering Menu is documented HERE. After making the change, restart the MMI system with the three-button restart procedure.
If you don't have VCDS, look at the Green menu activation script in the first post of this thread.
 
1 - 20 of 185 Posts
Top