Audi A5 Forum & Audi S5 Forum banner
541 - 560 of 612 Posts

·
Registered
A8 2015
Joined
·
77 Posts
@Wills1959 You don't need to spend two hours each time, as you only need to copy the files that aren't on the HDD. As @DrGER said above, you don't delete the Nav partition unless you're changing regions [NAR->EUR, for instance]. You're running in 'User Defined' mode, so just select the files off the SD that you haven't got on the HDD.

J
 

·
Registered
Joined
·
37 Posts
Thanks @JulianHicks . I am new to this game so just went on the instructions I got from the seller. So at the moment the nav database is empty. please excuse my ignorance but how do you test a SD card by copying files to my computer? Cheers
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
201 Posts
@Wills1959 : On what component are you getting the 141 error code ? As noted above, you could copy the contents of the nav update SD card to a new directory/folder on your PC, then confirm the installation file of that component is not corrupted by computing its MD5 checksum and comparing the computed checksum to the reference value given in the component's configuration file.

For example, if your navigation database update is failing on component PSD_ECE, you'll find the update files in the pkgdb/PSD_ECE directory, which should contain two files: filename.ATLAS and plain-text PSD_ECE.conf. The reference MD5 checksum is given in the PSD_ECE.conf file under the [file] section (MD5=...). On a Unix/Linux system md5sum computes the MD5 checksum. On Windows systems, certutil can be used to compute the checksum:

Code:
certutil -hashfile filename.ATLAS md5

When the computed and reference MD5 checksums are not the same, you know the file is corrupted. I describe this for download files HERE. --g
 

·
Registered
Joined
·
37 Posts
Thanks @DrGER. I am getting the error code after or during PSD3 and the full error says Device Reports error, Database-DBINFO:0, error code 141
I will try what you say above and see if I can get to the bottom of it. Cheers
 

·
Registered
Joined
·
37 Posts
@DrGER Tried copying the sd card to my computer and during the copy I am getting an unexpected error occurred the file or directory is corrupted and unreadable. Database file 1.99GB. So that is where the problem lies :-( :-(
 

·
Registered
Joined
·
37 Posts
Is there anyone out there willing to download the 2021/22 map update from here for the 3G High HN+ and put it on to an SD card for me. I am of course willing to pay for your time and for the SD card. My internet here is abysmal and I am lucky if I get 1mb download speed and even with that it is constantly dropping out. It would take me for ever to download such a large file. Thanks
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
201 Posts
Hi @JohnS4 I am on my second card now and there is no difference. Still get the error code 141 near the end :-( :-(
Do both Audi-branded nav database SD cards fail to copy to your PC at the same place (on the same file) ? If that's the case, (1) I would question whether these are counterfeit goods, and (2) request refund or resolution from the vendor given your evidence of a faulty SD card or corrupt file contents. --g
 

·
Registered
Joined
·
37 Posts
Hi @DrGER I have managed to copy the card on to my laptop now. It came up with an error and the old scan and repair which was carried out successfully.
I am now copying it to an external hard drive which I hope will work when plugged in to the usb in the glove box. If not I have a new card coming in the next day or so.
Thanks for your input
 

·
Registered
A8 2015
Joined
·
77 Posts
@Wills1959 I see that @DrGER has kindly explained the 'copy the files' issue to save me doing it. :)
My experience is that I can't get the update process to read anything other than the SD card although I do get the USB as an option.
If you're happy you've got all the files you need off the SD card, you could always reformat the SD card and copy the files from HDD to SD.

J
 

·
Registered
Joined
·
37 Posts
@JulianHicks Thanks for that info. I will try the usb option first and then the SD. I did see a video of some guy doing it the USB way and as he said himself it is far far quicker than the slow SD way
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
201 Posts
@Wills1959 : We'll be interested in how that works out for you (i.e., updating from the AMI/USB cable). The MMI update document that AoA published in 2016 doesn't reference the USB device as recommended (PDF HERE). @JulianHicks has a good suggestion -- try to (re)format one of the Audi-labeled SD cards as FAT32 and try that for the nav database update. --g
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
201 Posts
@JulianHicks Thanks for that info. I will try the usb option first and then the SD. I did see a video of some guy doing it the USB way and as he said himself it is far far quicker than the slow SD way
BTW, the AMI/USB connection is only USB 2.0, so not that fast, and has limited power for external devices like HDDs. I'd give this a try with a good USB 3.0 flash drive. Also, are you using an OE AMI/USB cable for this ? --g
 

·
Registered
Joined
·
37 Posts
@DrGER My external hard drive was formatting but I have cancelled it as I noticed that it is doing it in the NTFS format. The other option for it is exFAT
 

·
Registered
A8 2015
Joined
·
77 Posts
@JulianHicks Thanks for that info. I will try the usb option first and then the SD. I did see a video of some guy doing it the USB way and as he said himself it is far far quicker than the slow SD way
Yes, I've seen reference to the use of the USB interface too, but when I tried a USB Stick on a cable on my 2016 A8, it didn't recognise it.

Not sure USB disk it would be much faster though as you're limited by the write speed to the MMI hard disk ...

J

BTW; what folders did you get on the SD card you received from the 'dealer'? Did you get LIT/LIT2/LIT3/LIT4 or just LIT3GP/LIT3GP2/LIT3GP3/LIT3GP4 [plus others, of course]
 

·
Registered
Joined
·
37 Posts
@JulianHicks Hi, on the disk are the following under the folder pkgdb, cty2 and 3- CTYS3TC, CTYS3TC2 - GDB, GDB2 - Label - LIT3GP, 2,3,4,5 - LIT4 - NaviPersistence_all_3 - PIT - PSD, 2,3 - SDS - SDS3GP - StyleDBMMI3G_ECE_94 - StyleDBMMI3GP_ECE_9129 - TER , TER2 - TMC - TMC3GP - TMCConfig_16 - XAC - XAC2 - XAC3 and a few others not in folders :) :)
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
201 Posts
@JulianHicks Hi, on the disk are the following under the folder pkgdb, cty2 and 3- CTYS3TC, CTYS3TC2 - GDB, GDB2 - Label - LIT3GP, 2,3,4,5 - LIT4 - NaviPersistence_all_3 - PIT - PSD, 2,3 - SDS - SDS3GP - StyleDBMMI3G_ECE_94 - StyleDBMMI3GP_ECE_9129 - TER , TER2 - TMC - TMC3GP - TMCConfig_16 - XAC - XAC2 - XAC3 and a few others not in folders :) :)
Yeah, if you only got LIT4 on the SD card, I doubt this is legit (a proper nav update media for MMI 3G High/3G Plus will include all packages for both High & Plus systems). --g
 

·
Registered
Joined
·
37 Posts
@DrGER Doesn't sound too good. My previous car a B8 2.0 TFSI quattro Avant Dynamik, I got the upgrade from the same company and that went off without a hitch. Mind you the map came on a DVD which has to stay in for the Satnav to work
 
541 - 560 of 612 Posts
Top