Audi A5 Forum & Audi S5 Forum banner
3721 - 3740 of 3779 Posts

·
Registered
Joined
·
3 Posts
Can someone give me a tip on this please?? I did the green menu thing and it went fine but when trying to mount the updated version, it says 'no medium found' for some reason although i used the same SD for the green menu and it worked fine.. if it helps, my Media Version is: HN+_KR_AU3G_P0592 and i want to update it to Europe. Thanks in advance!
 

·
Registered
2011 Audi A8
Joined
·
119 Posts
If you're wanting to change the region of coverage, it's not as simple as loading a different map.

Search "region change" and you'll find more info.

Albert

Sent from my SM-G955F using Tapatalk
 

·
Registered
Joined
·
1 Posts
lol... 3722 posts in this thread

was looking for info to help me "unbrick" my RNS-850
 

·
Registered
Joined
·
80 Posts
My understanding of the process is that you may need to update the MMI software to K0942_6 in order to use the latest nav database, though I don't know what minimum version -GJ requires. I do know that if you update to K0942_6 (from the mega.nz archvie), you will need to activate navigation data when you update to -GJ from -CJ. The OP of the thread is the expert in that area.

My observations and experience with our MMI 3G+ is documented HERE.
Yes, in my case I need to upgrade FW first. Also trying to figure out the BO thing. Just posted on another thread here. Did not realize there are two. Anyone here willing to share BO experience? Looks like easiesest might be to get a bypass loop?
 

·
Registered
Joined
·
7 Posts
My understanding of the process is that you may need to update the MMI software to K0942_6 in order to use the latest nav database, though I don't know what minimum version -GJ requires. I do know that if you update to K0942_6 (from the mega.nz archvie), you will need to activate navigation data when you update to -GJ from -CJ. The OP of the thread is the expert in that area.

My observations and experience with our MMI 3G+ is documented HERE.
So, I have attempted this using both Congo's instructions and your instructions DrGER, using the link for the NA maps that you provided. Unzipped, the maps package seems to be around 20.9 GB between all 8 of the downloadable zipped packs. I have removed the previous maps from the database, but I had not let it wait until the system restarted automatically (oops). After rebooting, the MMI starts like it should, but the NAV goes into the frozen screen while initializing. Everything else continues to work fine. While trying to compare to see what it could be, i noticed that my MMI has "no valid acios_db found in /database". Any thoughts on what could be causing this? Am I somehow unzipping the map package incorrectly to only have a final size of 20.9 GB?
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
15 Posts
Any thoughts on what could be causing this? Am I somehow unzipping the map package incorrectly to only have a final size of 20.9 GB?
I don't claim any special expertise here, apart from having the experience of updating our 3G+ system several times successfully. Your unpacked nav update is likely correct if it unpacked at all (and the size is correct). Starting again by removing the nav partition in the GEM is one course of action to take. Deleting the current nav partition also removes the GEMMI (Google Earth) package, but if you don't need or use it already, you won't miss it.

BTW, acios_db appears to be related to nav data activation (it's referenced in the activator scripts). I don't know what it does (yet); I'll add this to my MMI-things-to-look-into to-do list

So, what software/firmware & nav database was installed before you attempted your update?
Did you need also to update the MMI software/firmware (before trying to update the nav database) ? --g
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
15 Posts
Yes, in my case I need to upgrade FW first. Also trying to figure out the BO thing. Just posted on another thread here. Did not realize there are two. Anyone here willing to share BO experience? Looks like easiesest might be to get a bypass loop?
Our '14 A4q has BO audio; the K0942_6 update did not affect BO on our car (that is, the update for "BO_Q7" was not applicable for our A4, and the DSP software in "AMPLCPKO" was already up-to-date, so this was a non-issue for us).
If you're concerned, I'd run the firmware update as "user defined" and don't update amplifier software listed in my Appendix E.
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
15 Posts
While trying to compare to see what it could be, i noticed that my MMI has "no valid acios_db found in /database".
This is what /efs-persist/navi/db/acios_db.ini looks like on our 3G+ system (after all processes are started & running):

Code:
# This file has been generated by the LVM (epoche 47)

ANY: /mnt/nav/db/pkgdb/CTYS3TC_NAR/3PN183NA18383P1460a.4_4.ATLAS
ANY: /mnt/nav/db/pkgdb/TER3_NAR/86_DTM_3G_NT_NAR.4_4.2.ATLAS
ANY: /mnt/nav/db/pkgdb/GDB_NAR/AJ831_v36a.gdb
ANY: /mnt/nav/db/pkgdb/GDB2_NAR/AJ831_v36a.gd2
ANY: /mnt/nav/db/pkgdb/TER_NAR/86_DTM_3G_NT_NAR.4_4.0.ATLAS
ANY: /mnt/nav/db/pkgdb/TMC3GP_NAR/kN183NAx01T01_3GPlus.db
ANY: /mnt/nav/db/pkgdb/PIT_NAR/AJ831b.PIT
ANY: /mnt/nav/db/pkgdb/XAC_NAR/kN183NAx01_0.db
ANY: /mnt/nav/db/pkgdb/XAC2_NAR/kN183NAx01_1.db
ANY: /mnt/nav/db/pkgdb/PSD_NAR/APN183NA18383P1458a.5_1.0.ATLAS
ANY: /mnt/nav/db/pkgdb/PSD2_NAR/APN183NA18383P1458a.5_1.1.ATLAS
ANY: /mnt/nav/db/pkgdb/LIT3GP_NAR/AJ831Pb_L1.db
ANY: /mnt/nav/db/pkgdb/LIT3GP4_NAR/AJ831Pb_L4.db
#SDS: /mnt/nav/db/pkgdb/SDS3GP_NAR/SDS_Data.iso
#MNT(SDS): /mnt/nav/db/pkgdb/SDS3GP_NAR/SDS_Data.iso
ANY: /mnt/nav/db/pkgdb/LIT3GP3_NAR/AJ831Pb_L3.db
ANY: /mnt/nav/db/pkgdb/LABEL_NAR/Label.DB
ANY: /mnt/nav/db/pkgdb/TER2_NAR/86_DTM_3G_NT_NAR.4_4.1.ATLAS
ANY: /mnt/nav/db/pkgdb/LIT3GP2_NAR/AJ831Pb_L2.db
The system startup script (/sbin/mme-becker.sh) references this with the "waitfor" command, suggesting that it may be auto-generated everytime by the LVM (?) process, and if acios_db.ini doesn't exist, nav startup fails.

See my MMI 3G+ QNX process listing over HERE; this shows a process called "vdev-logvolmgr", which likely has something to do with the acios_db.
 

·
Registered
Joined
·
80 Posts
Our '14 A4q has BO audio; the K0942_6 update did not affect BO on our car (that is, the update for "BO_Q7" was not applicable for our A4, and the DSP software in "AMPLCPKO" was already up-to-date, so this was a non-issue for us).
If you're concerned, I'd run the firmware update as "user defined" and don't update amplifier software listed in my Appendix E.
Or use a loop adapter?
 

·
Registered
Joined
·
7 Posts
So, what software/firmware & nav database was installed before you attempted your update?
Did you need also to update the MMI software/firmware (before trying to update the nav database) ? --g
I have upgraded it to the K0942_6 firmware, so it should be the most up to date one for my system I believe. My previous NAV was old enough that it never had GEMMI to begin with, so I wont miss much there.

This is what /efs-persist/navi/db/acios_db.ini looks like on our 3G+ system (after all processes are started & running):

/Snip

See my MMI 3G+ QNX process listing over HERE; this shows a process called "vdev-logvolmgr", which likely has something to do with the acios_db.
It's a bit overwhelming all the data spread over the different forums. I wasn't sure if maybe I was unzipping the files wrong, and missing something in the process. I will attempt the process again from the beginning and see if I can't get it operational.
 

·
Registered
Joined
·
7 Posts
I don't claim any special expertise here, apart from having the experience of updating our 3G+ system several times successfully. Your unpacked nav update is likely correct if it unpacked at all (and the size is correct). Starting again by removing the nav partition in the GEM is one course of action to take. Deleting the current nav partition also removes the GEMMI (Google Earth) package, but if you don't need or use it already, you won't miss it.
I just finished off reinstalling the maps, and it worked this time. I think the first time I had not unzipped the files properly and did not have all the necessary folders. Thank you for the links, and the help. It is much appreciated.

If I reinstall the firmware again will I have access to the GEMMI? Or is it even worth it?
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
15 Posts
If I reinstall the firmware again will I have access to the GEMMI? Or is it even worth it?
That's good news. Glad to help give back to the community.

As for GEMMI, if you have a working SIM for 3G data, you just need to install the GEMMI package (only) from K0942_6 as a user-defined update. Google Earth started working again a few weeks ago after being turned off for legacy MMI 3G systems in mid-December. Who knows how long they'll keep it turned on. --g
 

·
Registered
Joined
·
7 Posts
That's good news. Glad to help give back to the community.

As for GEMMI, if you have a working SIM for 3G data, you just need to install the GEMMI package (only) from K0942_6 as a user-defined update. Google Earth started working again a few weeks ago after being turned off for legacy MMI 3G systems in mid-December. Who knows how long they'll keep it turned on. --g
Ah okay. I don't have the SIM slot, so I will just leave it be. 🍻
 

·
Registered
Joined
·
2 Posts
At the risk of asking the same question for the millionth time, I seem to process things just a bit differently to the average Joe, to the point of my heading being ready to pop, and am a bit frazzled by it all. Anything with programming seems to cramp my brain. Few questions, hoping someone can answer.

Firstly, why are there two options, Modified firmware and Stock firmware? Is the latter in case you want to go back to stock, but going to Modified is the requirement for the update?
Next thought, why are there two updates listed? Surely everyone wants the latest? Or is it only an option for some? If so, whom? Either way, the later file does not seem to exist. Seemingly so anyway.
I will keep it going... I have HNR+R_EU_AU_P0518. I have an Australian (I believe it is the EU version?) 2012 A6 with 3G+, so I need the K0942? Yes?
That should do it, I just got to find an adapter for my 32gb Micro SD.
TIA
 

·
Registered
Joined
·
7 Posts
That should do it, I just got to find an adapter for my 32gb Micro SD.
TIA
I can't answer the rest, but I originally thought the same as yourself. I had planned to use an adaptor and Micro SD card, but it looked like some people were having issues with the card reading properly. I ended up just spending $20 and buying a regular card (it was on sale), and everything worked as it should. Once I got all the files copied over properly at least. :LOL:
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
15 Posts
Firstly, why are there two options, Modified firmware and Stock firmware? Is the latter in case you want to go back to stock, but going to Modified is the requirement for the update?
Next thought, why are there two updates listed? Surely everyone wants the latest? Or is it only an option for some? If so, whom? Either way, the later file does not seem to exist. Seemingly so anyway.
I will keep it going... I have HNR+R_EU_AU_P0518. I have an Australian (I believe it is the EU version?) 2012 A6 with 3G+, so I need the K0942? Yes?
That should do it, I just got to find an adapter for my 32gb Micro SD.
Regarding modified firmware: it's easy enough (if you know what you're doing) to modify the update configuration files in the archive to "Green Menu enabled / User Defined Mode / No Sound systems". Useful if you don't have a separate means of enabling the Green Engineering Menu to switch on User Defined Mode, and the last bit about removing sound systems so Bose & BO systems don't get clobbered on certain platforms (e.g., Bose on Q7). Otherwise, it's the same update as "stock". If you're MMI software is HN+R_EU_AU_P0518, you'll want to update to K0942_4 before touching the nav data.
Not sure what you mean by "two updates listed". Depends on the region for the nav data. In North America, it's 6.20.1 (8R0051884GJ), in the ECE region, it's different. And, of course, your region is different again. Note also that MMI 3G (High) and 3G+ (Plus) have a common set of nav data packages, but are distinct releases within a nav database update. So, the NAR 6.20.1 nav database update includes both 3G and 3GP releases, as does the ECE region.
Lastly: I'd avoid using a microSD card for this, especially updating the MMI firmware. The adapter "card" adds extra points of potential failure for the update. Get a good (Sandisk, Samsung, Kingston) 4 GB SD card for this (a good 2 GB SD card is sufficient). For the nav data update, a good 32 GB SDHC 80mbs+ is recommended. I've updated nav data twice with Sandisk SDHC Ultra cards, and haven't had any update failures.
 

·
Registered
Joined
·
2 Posts
Regarding modified firmware: it's easy enough (if you know what you're doing) to modify the update configuration files in the archive to "Green Menu enabled / User Defined Mode / No Sound systems". Useful if you don't have a separate means of enabling the Green Engineering Menu to switch on User Defined Mode, and the last bit about removing sound systems so Bose & BO systems don't get clobbered on certain platforms (e.g., Bose on Q7). Otherwise, it's the same update as "stock". If you're MMI software is HN+R_EU_AU_P0518, you'll want to update to K0942_4 before touching the nav data.
Not sure what you mean by "two updates listed". Depends on the region for the nav data. In North America, it's 6.20.1 (8R0051884GJ), in the ECE region, it's different. And, of course, your region is different again. Note also that MMI 3G (High) and 3G+ (Plus) have a common set of nav data packages, but are distinct releases within a nav database update. So, the NAR 6.20.1 nav database update includes both 3G and 3GP releases, as does the ECE region.
Lastly: I'd avoid using a microSD card for this, especially updating the MMI firmware. The adapter "card" adds extra points of potential failure for the update. Get a good (Sandisk, Samsung, Kingston) 4 GB SD card for this (a good 2 GB SD card is sufficient). For the nav data update, a good 32 GB SDHC 80mbs+ is recommended. I've updated nav data twice with Sandisk SDHC Ultra cards, and haven't had any update failures.
I already have the green screen activated via the VCDS. Soooo... I should be able to access the green screen, switch on the user-defined mode and I can use the stock fw? Am I understanding you correctly?
Well I did download the correct one at least. I will get uploading once I get my hands on a 32GB card. Which broaches two new questions... Can I use an even larger card? Or it accepts no higher? And why are you using two different cards? Just to save you going back and forth? I planned to load the first, go back to the computer, delete it, then load the map, then the activator.
Well what I thought were two different updates...
(8R0 060 884 GA - 6.28.2 2019 MMI 3G High/Plus Europe 2019
2020/2021
8R0 060 884 HF - 6.31.1 2020/2021 MMI 3G High/Plus Europe 2020/2021 ") <--- The date and version number both look later.
Though you are suggesting it is region-based and neither are suitable for me? As in I have to look elsewhere for this file?
Thanks for the reply!
 

·
Registered
2014 A4q 6MT MMI 3G+
Joined
·
15 Posts
I already have the green screen activated via the VCDS. Soooo... I should be able to access the green screen, switch on the user-defined mode and I can use the stock fw? Am I understanding you correctly?
Well I did download the correct one at least. I will get uploading once I get my hands on a 32GB card. Which broaches two new questions... Can I use an even larger card? Or it accepts no higher? And why are you using two different cards? Just to save you going back and forth? I planned to load the first, go back to the computer, delete it, then load the map, then the activator.
Well what I thought were two different updates...
(8R0 060 884 GA - 6.28.2 2019 MMI 3G High/Plus Europe 2019
2020/2021
8R0 060 884 HF - 6.31.1 2020/2021 MMI 3G High/Plus Europe 2020/2021 ") <--- The date and version number both look later.
Though you are suggesting it is region-based and neither are suitable for me? As in I have to look elsewhere for this file?
Thanks for the reply!
1. If you you have VCDS, you can apply the stock firmware (with the usual caveat about Bose or B&O sound).
2. The max SD size recognized is 32GB, which is needed for nav updates. Both firmware update and activator script will fit on 2GB SD cards, just make sure they are good quality.
3. The nav updates are issued by region. Look HERE for the current Australia/New Zealand nav database. The VAG part number for this SD card is 8R0051884EG. Good luck finding someone to share it on-line (helpful to ask, maybe someone has it to share). BTW, the post HERE might interest you.
 

·
Registered
Joined
·
2 Posts
What do you say about this video:
The instructions say that the firmware update must be done with the engine off.
 
3721 - 3740 of 3779 Posts
Top