Audi A5 Forum & Audi S5 Forum banner
1 - 20 of 240 Posts

· Premium Member
Joined
·
723 Posts
Discussion Starter · #1 · (Edited)
This is it!
The proper activator for Audi MHS2 systems made by delphi.
It a result of deep system analysis and some good reverse engineering.
The time has come and i have decided to share it!
Now is available free of charge for everyone!

Unlike the leaked version of the activator this one is tested and in use for quite long time now.
You will not loose ability to install custom POI's and for sure it will not cripple your legal function enabling codes.
I cannot guarantee that will work on every MMI out there, but i never had issues ever since i created it back in 2016.
Regardless of what some might say, update of the MMI is not mandatory. This is entirely up to you.
If your MMI is working properly and you have not noticed issues then you can continue using same version.
Believe me, i know these systems inside out.
As you will see bellow the supported versions list is quite long and will only get longer with time!
In case that you do decide to update then subscribe to this topic as i will update it to include software update info and files.

In the archive you will find a manual how to use it.
It is very simple process and you will only need one empty SD card size 8-32GB FAT32 formatted.
After activating the MMI you will be able to use latest navigation maps.

Here is list of supported versions, it was tested on many more but for now i decided to include the following.
If your software is not the support list then send the backup that the activator will make and i will add it. Always make sure you are using the latest version of the activator.
Almost any version out there!
If for some reason you cant get it to work following the manual then its likely that your unit was already patched.
In such case contact me and i will see what i can do about it.

Please have in mind that im doing this in my free time and that means that im not 24/7 available :)

The map of MHS2/MST2(soon to be released) is not installed, you copy map on SD and just insert in the unit. If coding is ok and fecs are shown as valid then map will work.
Simple as that :)


MAP 2022/2023 -> 11.64 GB file on MEGA
MHS2_ER_AU_K0129 -> 2.09 GB file on MEGA
MHS2_ER_AU_K0471 -> 2.53 GB file on MEGA
MHS2_ER_AU_P1242 -> 2.55 GB file on MEGA
MHS2_ER_AU_P2035 -> 2.54 GB file on MEGA

MHS2_US_AU_K0471 -> 1.02 GB file on MEGA
MHS2_US_AU_P1242 -> 1.01 GB file on MEGA
MHS2_US_AU_P2037 -> 1.02 GB file on MEGA
Software update instruction -> 720.9 KB file on MEGA
This document and activation are provided by THE PROVIDER "as is" and "with all faults." THE PROVIDER makes no representations or warranties of any kind concerning the safety, suitability, lack of viruses, inaccuracies, typographical errors, or other harmful components of this document. There are inherent dangers in the use of any software, and you are solely responsible for determining whether the procedure described in this document is compatible with your equipment and other software installed on your equipment. You are also solely responsible for the protection of your equipment and backup of your data, and THE PROVIDER will not be liable for any damages you may suffer in connection with using the information found in this document. You are also solely responsible for any modifications to the software of the MMI system, THE PROVIDER will not be liable for any claims from the vendor of your MMI system concerning the use of third-party software on the MMI system.
Selling this document and activation is forbidden.
Including this activation or its parts in any other tools should happen only after contacting me.

Attempts to modify the files might render the system inoperable.

Enjoy :)
 

· Premium Member
Joined
·
723 Posts
Discussion Starter · #2 · (Edited)
Update:
current version 2.4

If you used version older than 2.3 its recommended to install this one.
From version 2.2 and above there is option to remove the patched files in case the unit does not want to work ok or goes in reboot loop.
To do that take empty SD and create one empty file on it called "remove", put that SD in the unit and restart the unit. Once booted it should remove the patch and on next boot will start with stock software. This is only in case something with the flash goes wrong as there are some
events that can case data corruption and this might affect the SWaP process.

Whats new in version 2.4 - added check to help avoid potential failure where unit might not start after the first reboot. Although there was only one case and it’s not verified that latest version of the activator was used, I have decided to make minor change to help avoid such cases. No need to reinstall, this "bug" can be triggered only during install not after that.

Whats new in version 2.3 - moved the patched files from persistence to ffs partition. Although i never had such case there is a possibility that data corruption might happen in persistence partition. If you are running 2.2 you are kind of safe as in case something goes wrong you an always remove it. Process is documented in "Emergency removal" paragraph of the manual.

Whats new in version 2.2 - patch support for almost all firmware versions. Emergency removal option.
 

· Premium Member
Joined
·
723 Posts
Discussion Starter · #5 ·
That i can verify only after i have update pack that im able to install on my stock unit.
Wonder if it could be coding related.
So far all i get is "No valid update data found ... "
I dont ever use that so focus was never there.
 

· Registered
Joined
·
9 Posts
Fair point, needed some feedbacks to be sure. Anyway, I'm not sure if I have the right to ask, but I'm really curious how this activator in general works. From what I imagine it goes something like this:
  • creates a backup of the original files (regardless of the current situation of the system )
  • than checks if the system is already patched (if yes, you get red error message and the process is aborted - also in case of unsupported sw)
  • if the system is unmodified, process continues it's magic, replacing patched swap file and fec container (I wonder how these files are integrated in the script itself)
  • when job done, you are notified and the system reboots, deleting .sh script on the process (preventing restart of the script)

:unsure:
 

· Premium Member
Joined
·
723 Posts
Discussion Starter · #7 ·
You can please some of the people some of the time ...
Every now and then i get asked such questions. Because of the way i address them some people call me arrogant, but when you see the things that i've seen ...

I will try to be as polite as possible :)
  • Check if its already applied (this activator) is not made because of the way it works.
  • File is deleted before reboot yes, otherwise will end up in apply loop :)
  • Original files are kept too

btw i still cant install PersonalPOI even on stock unit.
 

· Premium Member
Joined
·
723 Posts
Discussion Starter · #12 ·
Hi,
as you can see this version is not on the list with supported versions.
If you check the manual you will see what the activator might do.
its all in the manual, common guys read that.
 

· Registered
Joined
·
4 Posts
Hi.

Firstly, thank you for this great piece of work.

The non technical among us really do appreciate the work people like you put in to keep our older kit usable in this modern world of upgrade/subscription insanity.

Would it be possible to clarify a few things?

I have a late 2016 A3 (A3 MY 2015-2018) with MMI Navigation system (Mobile data SIM, full USB interface)

I’ve applied the activation script without issues, and can see that there are now a lot more activation codes listed on my system.

I can get into the RED menu fine, but not the GREEN. No matter how long I hold the NAV + RADIO buttons. This means that I can’t follow the ‘User Defined’ section. Is this an essential step to upgrade the software, or can I skip this and just go ahead with the upgrade?

If you advise that I shouldn’t go ahead, can I just install the map update without the software update?

I’m not sure what benefits the software update would give me (currently working fine on MHS2_ER_AU_P0448, MU 0148), but the maps would certainly be worth while.

Thanks in advance,

TL.
 

· Registered
Joined
·
9 Posts
Since your current sw is not supported for patching (therefore you can't update maps) you have 2 options. First option is to upgrade your system to MHS2_ER_AU_P2035. You can do it via red menu as a standard update. Second option is that you apply the script which will create a backup of your system but off course it won't go any further as sw is not supported. You can than send your backup to the author of the script and he will prepare a patch for your version. In this case you don't need to update SW as you won't gain any additional features or visible improvements to the system. About the green menu - it can be activated only by VCDS/VCP. But for the patching and updating reasons there is no need to activate it at all.
 

· Premium Member
Joined
·
723 Posts
Discussion Starter · #16 ·
I’ve applied the activation script without issues, and can see that there are now a lot more activation codes listed on my system.
Hi, if you did that then you can just swap the cards thats it.
There is no MAP install here.

@Janch no update needed! A lot of software versions are supported and as you can see "802 - MHS2_US_AU_P0448" is one of them.

Advice to all users - if the recommendation does not come from me then better ignore it. I will not support other people mistakes!

Regards.
 

· Registered
Joined
·
9 Posts
If I understand his post correctly he's current SW version is MHS2_ER_AU_P0448 which (according to your description in OP) is not supported. With all due respect to the author, I won't reply to any other questions if you think that nobody else is competent to answer such questions...I just wanted to help. Peace! (y)
 

· Premium Member
Joined
·
723 Posts
Discussion Starter · #18 · (Edited)
Two guys asked, one with P0470 which is not yet supported but update is not mandatory and one with 448 which said that its installed already. Your reply is just after that one.
Maybe that caused the confusion maybe not.
The main point is - update is not mandatory, especially when there is so much things that might go wrong.

p.s. i see the confusion now. in the description is listed as 448 US but he have 448 EU
in reality they are the same in some parts. That's why he was able to install it :)
 

· Registered
Joined
·
4 Posts
Thanks for your advice.

I'm please to confirm that after acitvation the 2022 maps SD card works fine on MHS2_ER_AU_P0448.

Would updating to MHS2_ER_AU_P2035 bring any benefit over P0448 at all?

Maybe performance/security/stability?

Or is it just best to stick to the old adage 'if it ain't broke, don't fix it'?

Regards,

TL.
 

· Premium Member
Joined
·
723 Posts
Discussion Starter · #20 ·
New software will not give you visual improvements :(
It does fix some issues reported by users and in 2035 Audi switched from Google Maps to Here sat map, this option does require license.
If your system is working ok then yes "if it ain't broke, don't fix it"
But if you do decide to update then you can find all needed software here, there is a manual too.
After that just use the latest version of the activator and you will be able to use the new map again.
Regards.
 
1 - 20 of 240 Posts
Top