Audi A5 Forum & Audi S5 Forum banner
1 - 7 of 7 Posts

·
Administrator
Joined
·
473 Posts
I can see that the Lane change camera is reporting an error in the steering controller. What error is that as you didn’t show it in your post?

When you fitted the facelift wheel did you also change the clock spring or use the old one? Did you recode this in any way?

Perhaps the steering controller is still coded for the vibration motor which is no longer fitted and this is causing the error

You could try to recode the steering controller (remove the tick for vibration motor). This may work, however the Lane change camera may expect this to be there and report a no communication error.
 

·
Administrator
Joined
·
473 Posts
That error is short to ground, I would expect open circuit for a missing component. Check the plug and play loom. Something probably isn’t right.
 

·
Administrator
Joined
·
473 Posts
Hello, Welcome to the forum!

You should check the part numbers for the windshield/windscreen, I did this retrofit on an B8.5 A4 so have no real knowledge on a B9. The screen I used was 8K0... so definitely for a B8.

As you have a 16 plate, you may have the camera installed already and just need to enable lane assist. I do seem to recall a recent thread where I read that it had been done. If I find it I'll post back.

Re the high beam assist, again I have no knowledge of the B9. I can tell you that in the B8, high beam assist requires the extended CAN (high speed CAN) and a matching gateway. I have no idea if this is still required for the B9, but it may be of some help.
 

·
Administrator
Joined
·
473 Posts
So you’ll need a camera, loom, new screen, trim panels, steering switches, clock spring, coding and camera calibration.
 
1 - 7 of 7 Posts
Top