Audi A5 Forum & Audi S5 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all

New to the forum and Audis. I have just purchased an A5 Cabrio 2.0 tdi 65 plate. It's the special edition plus. Really pleased with the car but I think I have just created an expense for myself.

It all started a couple of days after buying the car - the dome lights near the rear view mirror stopped working - the ones mounted in the middle of the hood work just fine. All other electrics were just fine.

Being the clever chap that I am I decided to have a nosey at the fuses first so turned car off and pulled them all out one at a time, visually checked and replaced them all. None were blown.

On the next start and reverse of the car out the driveway I was disappointed to find that I heard no audible tone from sensors, nor did the reverse camera come on in the display.... SO I decided to this time disconnect the battery and check all the fuses again.

Again, none are blown.

I've reconnected the battery - tested but am getting no joy again from the sensors (front & back) nor the camera.

The menu in the MMI where you can set parking aid tones is all greyed out and I'm getting a message stating that the system is unavailable.

My instinct is I've thrown a code by pulling the fuses and so it probably needs a reset but I don't have access to diagnostics and don't at this stage want to pay the local dealer to cut my throat.

Am hoping someone out there can shed some light on my silly situation.- both with the sensors but also the faulty dome lights.....

Much appreciated!

Mo
 

·
Registered
Audi A5 f5 3.0 TDI Quattro S line S tronic Virtual Cockpit Driving assist pack
Joined
·
974 Posts
Hi,

welcome to the forums!
In your case to trouble shoot the issue, we’d really need a scan and see what fault codes it is.
If you don’t want to pay for a full fat VCDS cable like Ross tech offers then this could be an alternative: OBDeleven

here’s a basic tutorial:Basic OBD Eleven Guide (Android)

Also to note, you’ll need an android device to use as it connects to your phone via an app to use it.

i hope this helps if you choose either of the two routes above.
Most of all, keep us updated to how you resolve it.

~Alex
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi Alex

Thanks for the speedy response! I was getting a little worked up so in the end took it to the indy who does my MOTs etc who popped his Snap-On on to it.

Every code you could imagine was lit up - about 40 of them, after looking at first few we just bulk deleted and re-ran the check and it came up all clear.... and everything is back to normal again - sensors working as is the reverse camera.

So, moral of the story? Don't be a numpty and pull fuses to check them - get a tester and do it properly!

The front dome lights still don't work but at the moment I'm relieved thats all that's wrong with it... I will approach this with a new found respect and take a more delicate approach!

Have a good evening!

Mo
 

·
Registered
Audi A5 f5 3.0 TDI Quattro S line S tronic Virtual Cockpit Driving assist pack
Joined
·
974 Posts
If the dome light is out, more than likely the bulb has gone!
I’ve replaced both of mine before,
Step one, push the glasses storage out, you’ll see a screw in there holding it onto the roof. Once the that’s off, slowly pull the entire dome unit carefully, as ofcourse its loomed on! Once the wire is disconnected from the dome light, you actually access them small bulbs from the top of the unit! You have to turn left on the actual bulb holders and they come off, and then you replace them with 501 bulb type!

Hope this helps and link here for removal:


~Alex
 

·
Registered
Joined
·
703 Posts
You dont have to pull a fuse anytime actually. Only replace when broken, which actually also never happens.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top