Audi A5 Forum & Audi S5 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Hi Everyone.

I have a problem with my Electric Seat Retrofit. I installed the Drivers seat yesterday and its dead, no movement at all.

My car has just the normal crap seats (i mean they are totally crap seats) and wanted to retro fit with Heated Memory seats. My original seats are full manual. Zero power functions on them, no movement & no lumbar.

The seats I bought have memory and are heated. I bought the heated / Movement cable from Kufatec and have installed that into my current J519. From my understanding that should just effect the heating and/or memory function.

I havent installed the 15a fuse yet for the heating. Cable is wired just didnt have a 15a fuse handy.

Now I know the j519 in my car isnt compatible with heated memory seats so I have that sorted. I got a new one which will sort that, but its not fitted yet.

From reading the fourms the movement should just work without any coding required, but my seats are just dead. Like there is no power being supplied. Is there any additional power I need to run, or even give me the pin outs on the plug so I can start checking for the correct voltages. It was late when I finished last night so didnt get a massive amount of time to get it sorted.

Thanks
John
 

·
Registered
Joined
·
1,356 Posts
Suggest you check if there is power and ground 'there' before doing anything else.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
Thanks Morski. Thats first on my list. Hoping that someone with access to the wiring diagrams can help with the pin outs for the plug so I can check with a multimeter.
 

·
Registered
Joined
·
128 Posts
I would check if they getting any power first.
Have you got a manual how and where to connect all the stuff? I would love to have it on my computer as I will retrofit a set to my mates a5 in few weeks time
 

·
Registered
Joined
·
588 Posts
I have an original loom for sale at the momet if anyone is interested. No kufashit - wrong pinned and no support - crap.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #6
Unfortunately I dont have access to the wiring diagrams. Would someone who has be able to check and see what voltages I need from the power connector?

Baas, I would have snapped that up form you when i was getting the cable as I would have prefered an original. Good luck with the sale!
 

·
Registered
Joined
·
1,356 Posts
Just check if the power cable is supplying 12v and the ground is good as well.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #8
That's part of my problem is I have 12 v and 10v on the connectors but I'm not sure which is power to the motors? Hense I'd hope that someone can tell me which pins I I need to check
 

·
Registered
Joined
·
128 Posts
hope fully this weekend I will fit the heated mats into my fully electric seats so I will have a look if you still have not sorted it out by then
 

·
Registered
Joined
·
42 Posts
Discussion Starter #10
Thanks for the reply. Think I have it sorted. When I was doing it I know there was something obvious I was missing, so I just left for a while and realised what I missing. I checked the seat side of the plug on the electric seats versus the plug in the car, and there are two extra wires. One is the bigger AWG gauge wire so obviously that's power. The other is the memory wire. So I'll have to tackle those next week when I have time. I have ordered the missing pins for the car connector for both sides and will collect those today.
 

·
Registered
Joined
·
1 Posts
Ever figure out why they were not moving? I have a set that is in the same boat. I have power going to them and technically one of them did work for a few minutes for movement then stopped. Lumbar works on both so I know they are getting power. They are bench testing so i assume CP or what not would not matter. Any suggestions on what to test. I just need to get the power working. No need for memory.
 

·
Registered
Audi 2018 S5, 2007 3.2 TT, 2010 A5
Joined
·
72 Posts
i dont think you will get the memory function working easily as the module in the seat is security locked (component protection) to the car they were removed from - this can be removed by audi or some guys get techs to teamviewer in and remove it for a fee
 
1 - 12 of 12 Posts
Top