Audi A5 Forum & Audi S5 Forum banner
21 - 26 of 26 Posts

·
Registered
Joined
·
6 Posts
Hi @Deeyaz , I'm having the exact same issue but in the early stage of diagnosis and fixing (so far the spark plugs and coils are replaced), have you had any further progress? did you change the camshaft bridge?
 

·
Registered
Joined
·
3 Posts
Hi @shak679
I have managed to fix the problem by replacing the camshaft bridge bracket. The old mesh lining was broken and was causing the EPC light issue. Since replacing the camshaft bridge, I haven't seen the EPC light since so I'm guessing it solved the problem. Lucky your on the early stages of diagnosis lol I ended up changing 75% of the camshaft, changing the break pedal, the sensors and paying silly prices for diagnostics, to try and solve the issue. When all along it jus needed the bridge bracket replaced. If it wasn't for this forum I would have ended up paying loads tryna figure out how to fix this problem.
Apparently it's a common problem with VW/Audi. But most garages would rather change the camshaft or do a engine rebuild to milk you dry.

P.S you don't even need to take the bumper off to replace the camshaft bridge bracket, it's a tight gap but a good mechanic with the right tools can get it fixed within the hour or so.

Here's a link to the part I used for my Audi A5 2010 2.0 TFSI Quattro only £20 and I spent almost £160 prior tryna solve it ;( lol:
Audi A1 A3 A4 A5 A6 A8 Q3 A5 TT Camshaft Bearing Bracket Cover 06H103144H New 7061118508379 | eBay

Also watch this video which explains the issue kinda:
Skip to 5:30 for our issue^^

Also watch this video which explains how to replace the part aswell:
You'll also need a special tool to open it if your mechanic doesn't have it
Here's the link to it;

I did a lot of research and it took me months to try and figure it out thru trial and error, set back just over £300, but for you should be alot cheaper!
Thanks to this forum we finally got there ;')

Hope this helps, best of luck

Deeyaz out B-)
 

·
Registered
Joined
·
6 Posts
thanks @Deeyaz , I really appreciate your response. I have already bought this part (OEM Camshaft Adjuster Magnet+Solenoid+Bridge Bracket Fit for VW Audi 1.8/2.0TSI | eBay) bd the car is booked for tomorrow. I'm not sure if this is %100 right part or not. the part number on the actual part (06J 103 166 A) which is a bit different but the Audi part number is 06H 103 144 J). Based on what people say on the forums and as the seller claim these parts are interchangeable so this part should fit (my VIN is WAUZZZ8F1AN012346). I hope this fits.

Also, out of curiosity, the other problem I have (apart from rough idle and EPC light at 1200 rpm) is the car sometimes trying to jump/coughing when I come to stop. I hope this one also related to cam bridge. any thoughts?
 

·
Registered
Joined
·
3 Posts
Hi @shak679
Yup that's the right parts, that's exactly all the things I replaced, so should fit perfectly. Hopefully that's solves your problems let me know.

In regards to that jumping when coming to a stop I'm not too sure what exactly you mean? You said u changed Ur spark plugs that should stop your car from stuttering if you had a misfire cos I had something similar at high speeds the car will struggle or shudder but replacing all the spark plugs solved that.

Since you say it happens Wen coming to a stop maybe it's your brakes? Or your wheel alignment or maybe the steering wheel column, you should get them checked out and diagnose the problem.

Good luck mate
 

·
Registered
Joined
·
1 Posts
SOLVED: A5 2010 2.0 TFSI Chasing down an EPC Light

Hi and welcome to my thread.

I apologise now for the length of the post (but i hope it shows ive been using pointers off here before just asking for help). If you make it to the end.... you might be the hero I'm looking for!

Ive been reading this site for a while now and taken some guidance, but after a series of attempts to resolve my issue... I'm stumped.

Recently purchased my 2010 A5 2.0 TFSI 100K Miles - Has a warranty from my car seller extended to 15 months. (14/13 months left)

Before purchase

The car had a check engine light on. (turned out to be P0341 Camshaft Position Sensor - Circuit Range/Performance Bank1/Single Sensor) Car seller agreed to have the car fixed and it was sent to independant Audi specialist to have the work carried out.

Seller advised that Independant replaced the camshaft position sensor, which did not correct the fault and then replaced the manifold, which appeared to have corrected the fault. MOT completed and car returned to sellers dealership.

Check engine light returned onway back to sellers dealership. Seller advised me and I agreed with dealer that I would run the car over the weekend and see if I was happy, if I was, he would take it back to independant garage and have the work done.

When collecting the car, after a few hundred meters, the car began;

• really rough idling (shaking)
• misfiring extensively;
• smell of unburnt petrol;
• EPC light coming on while car under load;
• loud running (sounded like turbo whine)
• check engine light started flashing;

I pulled off road where safe and looked under the bonnet. The sound reminded me of a loose HT cap off my motocross bike, (dont ask what made me think of that). So I removed the plastic engine cover to see if I could visibly notice a loose coil pack/Spark Plug etc. I noted that the pipe to the right of the coil packs On top of the manifold was not connected. (presuming vac pipe).

See attached picture (circled in red);

It appears that this was loose when collected from independant and came away when I left seller dealership.

나는 파이프를 커넥터에 다시 밀어 넣었고 딸깍 소리를 내며 제자리에 고정되었습니다. 나는 차에 시동을 걸고 거친 공회전이 거의 완전히 사라졌습니다. (엔진이 밀리는 느낌이 들 때도 있지만 그 외에는 엔진의 구동은 거의 완벽에 가깝습니다.

나는 시험 운전을 위해 그것을 가지고 갔고 유일하게 남아 있는 관심사는 다음이었다; (이것은 현재까지 결함으로 남아 있습니다)

낮은 회전수와 부하 상태에서 가속할 때 자동차가 1,000~2,000rpm을 통과할 때 약 1,500rpm에서 한 번 잘못 발사되고 저크가 발생합니다. EPC 표시등은 1초 동안만 작동되며 가속이 계속됨에 따라 차량은 문제의 징후 없이 완벽하게 작동합니다.

이 문제는 교통 체증이나 시내 운전에서 가장 두드러지며 지속적인 정지 출발 운전이 있습니다.


지금까지 취한 조치

그 주말에 운전하는 동안 차는 잘 달렸고 처음 출발했을 때 실화 문제가 없는 것처럼 보였습니다. 체크 엔진 표시등이 실제로 지워졌지만 차가 따뜻해지고 작동 온도가 90도에 도달하면 1,500rpm 실화가 다시 발생하고 EPC 표시등이 1초 동안 트리거되어 체크 엔진 표시등이 다시 켜졌습니다.

OBD2(토크)를 차량에 연결하고 고장코드를 확인했습니다. P0341 – 파워트레인 캠축 위치 센서 "A" 회로 범위/성능(뱅크 1 또는 단일 센서)을 제공했습니다.

나는 ECU에서 결함을 제거하고 부하 상태에서 1,500rpm을 통과하지 않도록 차를 운전했습니다(2,000rpm에서 1차 출발). 이 작업이 완료되면 EPC 라이트 및 오작동이 발생하지 않습니다.

ECU를 다시 스캔했는데 오류 코드가 없었습니다. 교통체증에 다다랐는데 1초 동안 EPC 표시등과 함께 실화가 발생했습니다. EPC 표시등과 불발탄 직후에 다시 시동을 걸지 않고 차를 세우고 ECU를 다시 스캔했습니다.


오류 코드 P0341 - 파워트레인 캠축 위치 센서 "A"는 이제 보류 중인 "노란색" 오류였습니다. 점검 엔진 표시등이 반환되지 않았지만 보류 중인 오류가 있는 경우 ECU는 점검 엔진 표시등을 트리거하기 전에 특정 주기에서 설정된 횟수만큼 문제가 다시 발생할 때까지 대기하는 것으로 알고 있습니다.

..
Hi. I've been fixing Audi with the same symptoms as Audi in 2011. Did you fix the car?
 
21 - 26 of 26 Posts
Top