Audi A5 Forum & Audi S5 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
Anyone experience this problem.

I opened the car door to get something yesterday and the LED headlights came on. The switch is on auto and I thought nothing of it. Closed the door and went inside. However, 30 minutes later I looked outside and the lights were still on. I went outside and opened the door and the lights on warning sound beeped until I turned the switch from auto to off.

Next morning I start the car and I get the light malfunction warning indicator on my dash and no matter what position (off, auto, on) I set the head light switch to it turns both the headlights and the LED lights on.

Booked it in for service next Tuesday. Car is only 5 days old and this is the second time it's in the shop.
 

·
Registered
Joined
·
53 Posts
maybe it's telling you it wants to be driven
 

·
Registered
Joined
·
750 Posts
maybe it's telling you it wants to be driven
He-he...funny...

rob1234: I agree that is sounds electrical. Some cars (including BMW) have a strange behavior that is similar in that if you insert the key fob, as if you are going to start the car, and the "auto" lights come on, but then remove the fob...the lights will stay on until you either start the car or turn the "auto" light function off (but it can be enabled again right after).

Good luck, let us know how it turns out.
 

·
Registered
Joined
·
714 Posts
The first behaviour (LEDs still on) could be explained by the coming home function if the lights were set to auto.

At the back of my mind there's something telling me I've previously read that the lights might stay on as a warning that the car isn't properly secured? I think I read this over in some of the A3 forums but can't say where and can't say if it applies to the A5.

Given that you've now got a malfunction indicator it does sound like you're not suffering from a case of RTFM and the car needs to go in. My money is on the light sensor being defective but it's just a guess.
 

·
Premium Member
Joined
·
860 Posts
The coming/leaving home feature uses the fog lights on my car so I doubt it is that - besides they wouldn't stay on for 30 minutes.
 

·
Registered
Joined
·
435 Posts
The warning system is pretty accurate. THere is a button that has a wrench on it up on the dash. Push it. It will check all the systems of your car. When I was installing my radar dectector I accidently cut a wire in the overhead console. As soon as I turned the car on, it started screaming at me that there was a fault in the automatic headlights. When I soldered the wire back together the warning went away. You could have a loose wire or something. Moral of the story, if you are getting an error indicator, it is definitely not user error (unless the user cut a wire).
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #7 ·
Yeah, there's definitely a problem it's not only the LED's. If I set the headlight switch to off and I'm driving down the road in the middle of a sunny day the LED's and HID headlights are on. Same with auto position. I'm pretty sure in these cases only the LED's should be on. Also when set to auto and I shut the car off and try to get out it warns me that I left the headlights on but shouldn't it auto shut the headlights off when in the auto position.

Maybe the service guy hit a wire when he was trying to fix the window squeak because it started the next time I drove it after getting it home.

I'll update what happens on Tuesday after they take a look.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #8 ·
As what always seems to happen the warning light on the dash went off this morning on the way to the dealer and the lights went back to working normally after being broken for the last 6 days.

Dealer just cleared the codes and told me to see if it happens again. Not much else they could do as they couldn't replicate the problem.

Also, when I picked it up 15 minutes ago a bird had poo'd on my hood after I got it professionally detailed yesterday afternoon.
 

·
Registered
Joined
·
298 Posts
This happened to me once with m previous car (MB E500). I had entered the car through the passenger side turned the car on briefly to check something then turned it off. The lights stayed on until I repeated the process from the driver's side. Hope this helps.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #10 ·
Thanks. I'm not sure what caused it. I opened the drivers door to grab something and the lights came on and stayed on (in auto position).

They are working now anyway so hopefully it was just a glitch.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #11 ·
It happened again and this time was still broken when I brought it in to the dealer. They ordered a new head light switch for me so hopefully that will fix it.
 
1 - 11 of 11 Posts
Top