Audi A5 Forum & Audi S5 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just did a halogen to bi-xenon swap in my 2013 B8.5 A5 and used the instructions that came with my kufatec adapter. The lights, led ballast and biexenon ballast are installed.

The the kufatec high beam wires are ran to brown pin 3 and red pin 9, they are pushed in all the way.

I had a 8K0 907 063 DB onboard power supply and could not code 00 to 26 so I bought a 8K0 907 063 DH highline version

The following pins were swapped:

Brown pin 12 to red pin 5
Red pin 2 to red pin 4
Red pin 12 to brown pin 4
Brown pin 4 to red pin 12

I have a Hex Can USB VCDS.

I cannot change the following because everytime I try it says error 31 request out of range

byte 2 to 50
byte 3 to 91
byte 14 to 1D
byte 15 to 0D


Now I am getting fault codes:
01312 - Powertrain Data Bus
00497 - Sensor for vehicle leveling
03124 - Terminal 31-3 011 Open
01543 - Parking Aid Warning Chime
01324 - Control Module for AWD.

My headlights are flickering when driving

Also in the Headlight OFF position the passenger led strip is on and the drivers side led strip is OFF, but the drivers side side marker is on.

1. Any help on what to change to make the flickering go away?
2. Any ideas how to make the faults go away?
3. Do I have the pins swapped correctly?
4. Any ideas how to fix the led strip in the off position(one on and one off?


Thanks,
Scott
 

·
Registered
Joined
·
145 Posts
I done the same for somebody I know and the issue i came across was that the wire harness was from Kufatec so was wired wrong. Instead I returned it and used another on ebay and it worked properly.

Like yours it was a Facelift model to begin with and changed the halogen to xenon.

Also you mention you swapped some pins on the module which I didn't do.

Looking at some of the errors coming up tells me you need to code the module correctly as certain parts are not installed when you did the retrofit such as the 00497 error.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hassan,

1. I am surprised you didn't have to swap pins since the pins are different for halogen to bi-xenon, does your friends headlights work properly now?
2. What ebay harness did they end up buying?
I am thinking I am getting all the fault codes because my car is a premium and all the extra features on the new onboard power supply are from a premium plus and the computer is looking for the features which I don't have. I am just looking for a way to bypass these fault by telling the computer I don't have these features.
2. Does anyone know how to tell the computer I don't have these features?
 

·
Registered
Joined
·
145 Posts
Hassan,



1. I am surprised you didn't have to swap pins since the pins are different for halogen to bi-xenon, does your friends headlights work properly now?

2. What ebay harness did they end up buying?

I am thinking I am getting all the fault codes because my car is a premium and all the extra features on the new onboard power supply are from a premium plus and the computer is looking for the features which I don't have. I am just looking for a way to bypass these fault by telling the computer I don't have these features.

2. Does anyone know how to tell the computer I don't have these features?


You need VCDS to code the module. What I did was use the previous coding from the old module and worked around that.

Only issue I could not resolve was component protection on the new module which I just took to dealer and they sorted it out.

Everything now working as it should.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
17 Posts
I just did a halogen to bi-xenon swap in my 2013 B8.5 A5 and used the instructions that came with my kufatec adapter. The lights, led ballast and biexenon ballast are installed.

The the kufatec high beam wires are ran to brown pin 3 and red pin 9, they are pushed in all the way.

I had a 8K0 907 063 DB onboard power supply and could not code 00 to 26 so I bought a 8K0 907 063 DH highline version

The following pins were swapped:

Brown pin 12 to red pin 5
Red pin 2 to red pin 4
Red pin 12 to brown pin 4
Brown pin 4 to red pin 12

I have a Hex Can USB VCDS.

I cannot change the following because everytime I try it says error 31 request out of range

byte 2 to 50
byte 3 to 91
byte 14 to 1D
byte 15 to 0D


Now I am getting fault codes:
01312 - Powertrain Data Bus
00497 - Sensor for vehicle leveling
03124 - Terminal 31-3 011 Open
01543 - Parking Aid Warning Chime
01324 - Control Module for AWD.

My headlights are flickering when driving

Also in the Headlight OFF position the passenger led strip is on and the drivers side led strip is OFF, but the drivers side side marker is on.

1. Any help on what to change to make the flickering go away?
2. Any ideas how to make the faults go away?
3. Do I have the pins swapped correctly?
4. Any ideas how to fix the led strip in the off position(one on and one off?


Thanks,
Scott


Hi NewNavy101,

Did you ever end up figuring out what the issue was?

Im pretty much in the same predicament as you had, kufatec adaptors installed, high beam wires run to the j519 (8K0907063DH). trying to code the drl's to turn on but its rejected in VCDS with the same error (error 31)

Xenons, high beam flash, indicators all work fine, only DRL's i cannot activate at the moment.

Any help would be much appreciated!
Thanks
Harj
 
1 - 5 of 5 Posts
Top