Audi A5 Forum & Audi S5 Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
AUDI A5 TDI. While driving it brings up the message gearbox malfunction and a few seconds after that parking brake malfunction. It is then when it cuts out the gears, I have to stop, shift to neutral, switch it off, shift to park, then it starts and I can drive. Some days it is OK and then the next day it will start doing it again.
Please advise.
 

· Registered
Joined
·
1,830 Posts
Which transmission is in that car?
 

· Registered
Joined
·
1,830 Posts
There can be a number of issues with that gearbox and unfortunately the older versions are more prone to experiencing them. The earlier versions could develop problems with the mechatronics with the result of "missing" gears. Sometimes there could be complete selection failure if the control PCB gets overheated (a design issue). There can also be a problem with the select lever sensor affecting gear changes. For higher mileage cars the clutchplates can become worn and this will cause overheating.

Your issue sounds like the mechatronics is faulty. Can you get a diagnostic scan?
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
There can be a number of issues with that gearbox and unfortunately the older versions are more prone to experiencing them. The earlier versions could develop problems with the mechatronics with the result of "missing" gears. Sometimes there could be complete selection failure if the control PCB gets overheated (a design issue). There can also be a problem with the select lever sensor affecting gear changes. For higher mileage cars the clutchplates can become worn and this will cause overheating.

Your issue sounds like the mechatronics is faulty. Can you get a diagnostic scan?
Thank you Dippy.
Mechatronics was done 48 000km ago. Did a diagnostic. It says "Drive position sensor - electrical malfunction"
at first they were not sure but seems they are going to replace the Auto Transmission Shifter. Reckon it's the electronics on the Shifter that's faulty. Hope it works.
 
1 - 5 of 5 Posts
Top