Audi A5 Forum & Audi S5 Forum banner

121 - 140 of 147 Posts

·
Sponsor
Joined
·
2,384 Posts
I removed the entire manifold. The junction where the pipe joins the manifold was almost entirely jammed.
 

·
Registered
Joined
·
18 Posts
I removed the entire manifold. The junction where the pipe joins the manifold was almost entirely jammed.
I tryed that , but still no solution . I will try to replace that "solenoid" . After that only left is EGR cooler . I really was hope that this cleannig manifold will solve ,and it was dirty ,expecially that lilte part that comes from EGR ... But still error ?

Does anybody know what is purpose of that solenoid near the EGR ?
 

·
Registered
Joined
·
19 Posts
Replacing my EGR fixed the issue.

Go for a short drive, when you get back lift your bonnet and have someone switch the engine off.

Put your ear down to the EGR and see if everything sounds healthy. A few seconds after switching the Engine off it closes. Mine sounded like a bag of bones. The cog mechanism had clearly deteriorated and wasn’t able to fully open/ close the valve.

This might help identify the source of your problem.
 

·
Sponsor
Joined
·
2,384 Posts
The solenoid didn't solved p0401. Dont know what to do any more. Starting to hate AUDI.
Remove the EGR valve and clean it, if that doesn't work clean the cooler. If that doesn't work, it's almost guaranteed to be a sensor issue.
 

·
Sponsor
Joined
·
2,384 Posts
I replaced new egr
I cleaned complete intake manifold
Replaced solenoid.
Only left is cooler ? Only error on diag is p0401 intermittent .
Likely the cooler then, its a complicated shape internally and would easily clog. You can probably clean it, but removing it is a pain in the ass.
 

·
Registered
Joined
·
351 Posts
See these earlier posts on this thread: #62:
TPI released in November 2012 for MY08-10 for this P0401 error and it is regarding the EGR cooler replacement.
Also see post: #39

So most coolers have aready been replaced.

TPI says: EGR cooler maybe cloged after 40000 km, so if the car has more than 40000 km, You have to change EGR cooler.
EGR cooler changed and the faultcode hasn't come up since.
TPI 2024204/7
 

·
Registered
Joined
·
18 Posts
I will try to clean . Also i previously changed maf sensor by dome mistake . Got p0101 ... reason was dirty air filter. So maf replaced unnecessary... i will put old original maf
 

·
Registered
Joined
·
351 Posts
Jet- What engine & year is your A5?
 

·
Registered
Joined
·
351 Posts
You have a PM (message)- not sure if you can reply to it yet as a new member?
 

·
Registered
Joined
·
18 Posts
Today i was at AUDI Center . They told me almost the same as you sayed here. Clean small pipe from EGR .
They looked at ODIS and AUDI recomedention is first change EGR ( electric part ) , then EGR ( mechanical part - cooler ) ,after that software adaption of EGR. If that dont solve problem then Update ECU with new audi firmware . Mine now is already updated ,but not to the last version . Starting version is SW 060 , then 070 , 080 and i think final is 090 for my car . My is SW 080. They do the adaption of EGR ,but that didnt solved P0401 . I will try cleaning cooler and the last try software update.
 

·
Registered
Joined
·
577 Posts
Definitely cheak small pipe, did mine & it cleared fault 20k miles ago & not come back


Sent from my SM-N950F using Tapatalk
 

·
Registered
Joined
·
18 Posts
I do that . Maybe solution is found ... After cleaning that pipe , replacing new EGR , i didnt actually do adaptaion of EGR , yesterday i do adaption in AUDI CENTER ,but with my old MAF ( i replaced it , hoping that new MAF is not ok xaxax ) and after adaption with old MAF after few kilometeres P0401 . Now i Put new MAF . RPM is little higer ( aroud 700rmp) With old maf was 630 rmp . Now drive a little ,for now there is NO P0401. But dont be happy to soon :) Tomorow i will take to longer distance and check .
 
121 - 140 of 147 Posts
Top