Audi A5 Forum & Audi S5 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all,
This is my first post on here and unfortunately isn't the best one.
Over the lock down I have been doing some mods to my headlights, meaning I have not been able to drive the car. I have started it and left it running a couple of times, but now running into a problem where the car starts, idles really rough and pretty much dies a few seconds later.
I have scanned the car with VCDs and getting the following codes

Address 01: Engine Labels: 059-907-401-V1.clb
Control Module Part Number: 8K1 907 401 D HW: 8K0 907 401
Component and/or Version: 2.7TDI EDC17 H01 0006
Software Coding: 0114002C02070120
Work Shop Code: WSC 06325 123 12345
ASAM Dataset: EV_ECM27TDI8K1907401D A01006 (AU48)
ROD: EV_ECM27TDI8K1907401D.rod
VCID: 2D516F917CC0AD2954-8078
2 Faults Found:

5227 - Fuel Rail/System Pressure
P0087 00 [096] - Too Low
Intermittent - Not Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 1
Mileage: 171584 km
Date: 2020.06.10
Time: 19:23:55

Engine speed: 906.00 /min
Normed load value: 0.0 %
Vehicle speed: 0 km/h
Coolant temperature: 16 °C
Intake air temperature: 14 °C
Ambient air pressure: 990 mbar
Voltage terminal 30: 11.320 V
Unlearning counter according OBD: 40
Crankshaft speed (RPM): 906.0 /min
Vehicle speed: 0.00 km/h
PCV p Set: 1.4871e+006 hPa
Fuel temperature: 12.9 °C
Fuel high pressure: actual: 272400 hPa
Rail pressure regulation: status-Bit 0: 00000100
Inj Crv st Inj Char Act Val 0-Bit 0: 00110100

4894 - EGR Valve (N18)
P0403 00 [237] - Malfunction
MIL ON - Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 1
Mileage: 171584 km
Date: 2020.06.10
Time: 19:30:52

Engine speed: 0.00 /min
Normed load value: 0.0 %
Vehicle speed: 0 km/h
Coolant temperature: 16 °C
Intake air temperature: 14 °C
Ambient air pressure: 990 mbar
Voltage terminal 30: 11.800 V
Unlearning counter according OBD: 40
Crankshaft speed (RPM): 0.0 /min
Vehicle speed: 0.00 km/h
Vehicle voltage terminal 30: 11880 mV
EGR valve feedback: 2.98 %
EGR Vlv r Tmp Ofs: -5.00 %
EGR Vlv st Adap-Bit 0: 00000000
EGR Vlv st Adap-Bit 8: 00000000
EGR valve status learning-Bit 0: 00000000
EGR valve status learning-Bit 8: 01000000

I have replaced the inline fuel filter as heard they can get pretty clogged, but that unfortunately made no difference. I have also tried with the MAF sensor disconnected, but also with no joy.

I have heard of people having problems with the Hire Pressure Fuel Pump, but not whilst also having the EGR fault.

Any ideas/suggestions? Also, is there any guides on how to remove the HP fuel pump and EGR for the 2.7/3.0 Diesels?

Thanks in advance
 

·
Registered
Joined
·
69 Posts
Well i'd start with the EGR first. Forget the HP fuel pump for a minute.


Sticky EGR valve may be the root cause (we hope). Plenty of vids on youtube of how to remove and clean. Or give it to a garage and ask them to clean it out (if you can get it moving).

This - "I have started it and left it running a couple of times,.." - i don't think helps things in a modern diesel. Will possibly help contribute to blocking a DPF as you're not actually driving it to perform a cleaning cycle. Can you force a regen with VCDS (if needed)?

Also, have you fit the inline fuel filter correctly? They flow one way (filter canister has an arrow on it for flow direction i think?).
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the reply savs.
I will take the egr valve off and give it a clean over the weekend.
You could be right, I was just following the advice of the AA and others. If the dpf was blocked would I not be getting the dpf warning light too? Also the car does not idle long enough to perform a forced regen through VCDS.
I installed the filter with the same flow direction as the previous one in it.
 

·
Registered
Joined
·
69 Posts
Hey Alex

The DPF should be fine. Just keep an eye if idling for long periods. As you say the DPF light should come on when filter getting full and needs a forced cycle (driving or VCDS etc).
Good about the fuel filter. Just double checking ;) Can be an easy missed mistake i think.

Yeah, try the EGR and see if it improves? As least if you can remove you can inspect it? See if it really is clogged up?

On a side note, my last A5 was the 2.7TDi. I loved it. A lot of people don't like the multitronic box (i'm not sure a lot of the haters have actually driven it). But i really liked the smoothness of the box. A pleasure to cruise in! Just make sure the gearbox oil is changed at specified intervals (30k miles i think??) and it'll run smooth.

Regardless of what i say above, i'm hoping a better person can interpret your VCDS error codes above and give advice as well.
 
  • Like
Reactions: SimonRoma

·
Premium Member
Joined
·
2,437 Posts
Well done SAVS sound words indeed!! Any more experts able to help here please???
 
  • Like
Reactions: AlexHedley
1 - 5 of 5 Posts
Top