Audi A5 Forum & Audi S5 Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Hello!


I got two faults on my Audi a5, which i may believe can be connected to eachother somehow.. Therefore am i posting this post here before i leave the problem to the workshop.

Its an Audi a5 3.0tdi -07

I have fault message in display; "Parking brake malfunction" but, the parking brake is 100% functionable
Also i have a fault that the battery keeps draining, so i have to keep it connected to charger all the time- but it wont raise more than 10-20% battery level.
The battery is new and is in good condition.

Those problems occured almost at the same time- First, i had issue with "parking brake malfunction" which came periodically, but now it is like that all the time.
secound, the car was completely dead battery.


Anyone had issue with this before?
Is there any known faults i can start looking at before i deliver it to Audi dealership??


Is there any cable or so that could be ripped of from parking brake and going to earth?
And again, the parking brake is 100% functionable

Sorry for bad english, hope to hear from you guys.


Best regards
 

·
Registered
Joined
·
5 Posts
Patrick did you find out what the problem was ? I have a similar issue where the battery drains over night , when I lock the car the lights all go out as normal but then after a minute the handbrake light and "P" on the dash illuminate along with purging of different components under the bonnet , its as if the car will not go to sleep and it has between a 3amp and 5 amp drain o the battery ?
 

·
Registered
Joined
·
4 Posts
I was having similar issues with my 2009 S5 (V8).

I would get the following as well...

* Parking Brake Malfunction
* Headlght malfunction (turning headlights)
* Tire Pressure warning
* Power Steering would stop working a few times
* Doors wouldn't unlock with keyless entry
* Transmission limited functionality (that was the scariest by far!)

I already knew my battery was low since I had to jump start the car several times.

I had a new AGM battery (Die Hard brand here in the USA) installed a few days ago and everything is fine and back to normal!!


Seems that our cars need a lot of power for all the systems to work properly otherwise they go into a self-preservation power saving mode by shutting down some systems.
 

·
Registered
Joined
·
4 Posts
Patrick did you find out what the problem was ? I have a similar issue where the battery drains over night , when I lock the car the lights all go out as normal but then after a minute the handbrake light and "P" on the dash illuminate along with purging of different components under the bonnet , its as if the car will not go to sleep and it has between a 3amp and 5 amp drain o the battery ?
Did you find out what cause the problem? I have something similar.
 

·
Premium Member
Joined
·
3,690 Posts
These cars are indeed very battery sensitive. AND I have also read that a new battery may need to be programmed to the car. When the battery starts to run down best to change it for a good brand new one without delay!
 

·
Registered
Joined
·
560 Posts
These cars are indeed very battery sensitive. AND I have also read that a new battery may need to be programmed to the car. When the battery starts to run down best to change it for a good brand new one without delay!
Yes, if your car has the auto engine stop and start feature, then I believe you need to update the computer via VCDS/scan tool after you change the battery.

My U.S.-spec 2013 A5 does NOT have that feature, so I just replaced the battery (w/ regular flooded lead acid) and didn't do anything else. It's never had any problems.
 

·
Registered
Joined
·
4 Posts
I don' t think thats gona help, because when i lock the car, parking ligts on the display and on the parking button flashes. After couple of seconds shuts down ant flashes again untill battery is dead. Meanwhile when this is hapening i hear some clicking noises in the right back side of the trunk.
 

·
Registered
Joined
·
2 Posts
Hi, did you get to the bottom of this problem. I have a very similar problem. After I stop the car and lock it I hear 3 clicks from the rear of the car and the P brake light comes on in the cask as well as the parking brake button to operate the park brake. It goes off and on continuously until the battery is run down. I have replaced the battery so I know it’s good. I have noticed that if I leave one door open It won’t do it. Really frustrating
 

·
Registered
Joined
·
4 Posts
Well my problem was trunk control module. My trunk is electric. I had to change that module and now everything is ok. You can find it somewere in the left of the trunk. I had to go to audi official service. New one cost 280 eur. But i found a used part for 150 eur. I hope it will help.
 

·
Registered
Joined
·
2 Posts
Thanks Ego, I think you’re right. From everything I have read so far it looks like this can be caused by a number of different things but manifests in the same type of way I.e. the park brake lights and the clicks from the trunk etc. I have numerous faults showing when I run the diagnostics so I’ll work through them one by one. The first being the AC pressure sensor which showing a fault and it has been found to be the issue for others so I’ll replace it first and go from there. Thanks again.
 

·
Registered
Joined
·
1 Posts
Hi, did you get to the bottom of this problem. I have a very similar problem. After I stop the car and lock it I hear 3 clicks from the rear of the car and the P brake light comes on in the cask as well as the parking brake button to operate the park brake. It goes off and on continuously until the battery is run down. I have replaced the battery so I know it’s good. I have noticed that if I leave one door open It won’t do it. Really frustrating
I have exactly this problem with my Audi A4 B8 2010, have you solved it yet? And if so what was the problem? I will be very happy if you could help me
 

·
Registered
Joined
·
3 Posts
Patrick did you find out what the problem was ? I have a similar issue where the battery drains over night , when I lock the car the lights all go out as normal but then after a minute the handbrake light and "P" on the dash illuminate along with purging of different components under the bonnet , its as if the car will not go to sleep and it has between a 3amp and 5 amp drain o the battery ?
Did you get sorted at all ?
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #16 ·
Hi, this is now so many years ago, and I really dont remember what caused the issue (been so much)

The cause of the battery was a dead new battery. I bought banner agm now and been working perfect.
 

·
Registered
Joined
·
3 Posts
Thanks Ego, I think you’re right. From everything I have read so far it looks like this can be caused by a number of different things but manifests in the same type of way I.e. the park brake lights and the clicks from the trunk etc. I have numerous faults showing when I run the diagnostics so I’ll work through them one by one. The first being the AC pressure sensor which showing a fault and it has been found to be the issue for others so I’ll replace it first and go from there. Thanks again.
Gerry, any joy with yours at all ?
 
1 - 20 of 21 Posts
Top