Audi A5 Forum & Audi S5 Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys, I hope you are fine. I am writing regarding my 2007 Audi s5 4.2 with a manual gearbox. I was driving it 3-4 months ago when the parking brake malfunction warning came up. However, the parking brake worked fine (it was engaging properly). Some time after that (2-3 days), the amber engine check light came up and the car started having some sort of "hiccups". Consequently, I took it to my mechanic. They checked the codes, there was something about the fuel and oil leaks together with the maf sensor what has been fixed by replacing the broken fuel pump and the rocker gaskets cover. They thought that the faulty fuel pump and the oil leak might be causing the maf going crazy what was resulting in the "hiccups". The errors were deleted following the repair. However, 2 weeks later, the issue came back. In a result, the car was given new map sensor as they thought that it can be broken what makes the maf sensor failing. And again, the issue came back. According to the parking brake malfunction, the parking brake module was replaced, but obviously it has not fixed the parking brake malfunction problem. Consequently, I took the car to the mechanic again, they checked all the cables, they said there are fine, but they found out that one of the cells in the battery was dead. In a result, the battery was replaced. I was happy that the issue has been finally resolved, but it came back again - engine "hiccups" (engine check light) together with the parking brake malfunction warning. Obviously, I took it back again to the mechanic, they managed to find some sort of an air leak which was fixed. I collected the car last week and read on some forums that the parking brake malfunction warning comes up in audi cars whenever there is something wrong in the engine what would make perfect sense why it was on what together with the hiccups and the air leak that it was accompanied by. However, both of the warnings came back again yesterday what obviously makes the car having hiccups again. I am literally desperate to find out what is wrong with it. I cannot feel any issues with the power. The car is a bit rough sometimes, especially when I release the gas pedal on the second/third gear (i can feel it pulling). I thought it might be the maf sensor, but it was checked at the first place and seems to be fine as well. Has any of you experienced anything similar or at least have any suggestions what might be going wrong with my lovely s5?
 
1 - 1 of 1 Posts
Top