Audi A5 Forum & Audi S5 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone, hope I can get some help here to even just troubleshoot. About 2 weeks ago I had a fault show up being P0090, the car went into limp mode. I pulled over to the side of the road and turned the car off and on and it was fine again for the rest of the journey.

the next few days or so I realised it only showed the fault code when the car had only started and wasn’t warm so I just let it heat up drove slowly until I felt I could go into the boost rev ranges.

however just yesterday the fault has came on and the car refuses to use the turbo. No limp mode until I hit the boost ranges (about 2000rpm) then the car just loses all power.

the exact code is P0090 fuel pressure regulator 1 open circuit. How do I go about diagnosing this, weather it’s a sensor, poor wiring or the FPR itself? And where abouts would it be located?
 

·
Registered
Joined
·
67 Posts
Its at the back of one for the fuel rails.

 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Brilliant thanks! Would it be a good idea to unplug the sensor to see if the fault stops showing up? If the fault disappears it would prove it’s something to do with wiring/ sensor?
 

·
Registered
Audi A5 f5 3.0 TDI Quattro S line S tronic Virtual Cockpit Driving assist pack
Joined
·
874 Posts
A fuel pressure sensor is pretty cheap circa £35/40 for the 3.0 TDI engines.

Deffo worth replacing! 🙌🏻

~Alex
 
1 - 5 of 5 Posts
Top