Audi A5 Forum & Audi S5 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys I’m new here. I recently bought a 2017 s5 b8 only had the car 2 months and I have major issues with electrics. Car has been sat at the service centre for 2 months and they are still scratching there heads and don’t know what is wrong. Any advice on this would be great.
 

·
Registered
Joined
·
1,599 Posts
Your car is a B9.
It suggests a severe comms problem, so severe that even the diagnostics may not be working. In such cases it needs to be stripped back to the bare minimum until the diagnostics start working and then modules reconnected one by one. Perhaps the service centre don't have techs with suitable skills.
 

·
Registered
Joined
·
9,105 Posts
Assuming its over 3 yrs and out of audi warranty

I hope you bought from a dealer. Regardless of any written warranty if they can't fix it in 2 months and don't know what's wrong reject it for a full refund.
 
  • Like
Reactions: SimonRoma and savs

·
Registered
Joined
·
3 Posts
Check your Battery. This kind of failure reguraly comes from a battery problem.


Envoyé de mon iPad en utilisant Tapatalk
 

·
Registered
Joined
·
80 Posts
As above - get service centre to check ( and replace) battery. If its on its way out it can throw up random faults to be displayed.

If you bought the car 2 months ago and its been in a service centre for those two months then i would give an ultimatum for a fix date or a full refund on the car (assuming you bought from a dealer). Its nowhere near good enough to not have actually had the vehicle since you've bought it!
 
  • Like
Reactions: SimonRoma

·
Premium Member
Joined
·
2,643 Posts
Goodness those are some very heavy fault messages mate. I too would tend to leave them the car and reject it IF they cannot fix it in a reasonable time. You need to talk to a solicitor. I guess that you did not purchase from an Audi dealer cos you mention Ross Tech???
 

·
Registered
Audi 2018 S5, 2007 3.2 TT, 2010 A5
Joined
·
72 Posts
i think most of those systems go through the J519 module (its in the passenger side footwell, left hand side), id also check all the fuses, does the vagcom get a signal from each of the modules? where abouts are you based? id also ask them to hook up the can lo/hi up to a an oscilloscope to check for interference (then unplug modules to see if it clears up)
 
1 - 9 of 9 Posts
Top