Audi A5 Forum & Audi S5 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all, I need some help please!!!!
I have a 2008 A5 with B&O ICE, I have no sound from anything (sat nav, phone, radio, CD, etc) the sat nav works, the radio tunes in fine, phone connects, cd’s are “whirring” but no sound. I had the mute light on problem when I got the car, I had the amp serviced and everything was fine for a couple of months, now nothing and no mute light. I’ve checked all fuses, there’s no water ingress and I’m out of ideas? TIA
 

·
Registered
Joined
·
133 Posts
Hi all, I need some help please!!!!
I have a 2008 A5 with B&O ICE, I have no sound from anything (sat nav, phone, radio, CD, etc) the sat nav works, the radio tunes in fine, phone connects, cd’s are “whirring” but no sound. I had the mute light on problem when I got the car, I had the amp serviced and everything was fine for a couple of months, now nothing and no mute light. I’ve checked all fuses, there’s no water ingress and I’m out of ideas? TIA
Honestly - sounds like the amp has finally given up. Not sure how an amp is 'serviced'. Someone can only touch up solder joints if they are looking dry looking dry. At best they can replace components if damaged (DSP chip fails if water damaged).

Can you get the amp out of car and open it up to check for any damage inside? I had the 'analogue' part of the amp go. Big black burn mark. Digital side was ok. Replaced the amp board from a similar of ebay and has worked fine since.
If digital side needs replacing or module needs replacing (check ebay) then module will need recoding to car.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you for the reply, when I say serviced, it had a complete new “mother board” if that’s the correct word, at great cost!! (£400 if I remember correctly)
 

·
Registered
Joined
·
133 Posts
Thank you for the reply, when I say serviced, it had a complete new “mother board” if that’s the correct word, at great cost!! (£400 if I remember correctly)
Ah ok. Yep makes sense. And yep, it does cost. Did Audi do it or a third party. Some places will put a used mother board in and reprogram to your car. But, it'll still be an old board.

See if you can get the amp out? There' a sticker under it which gives the number (example - mine was 8TO 035 223 H. This was for a B8 10KANAL Most DSP).
Where B8 is car model (2009 A5)
10K ANAL is not something from a gogle site! But means analogue amp (i am guessing 10 for 10 channels though)
MOST is the fibre optic data line to connect the amp, stereo, CD, MMI etc
DSP means the motherboard. Where DSP is the 'digital signal processor' chip. This gets water damaged or can just fail (electronics..)
Using the above you can plan for worst case of swapping something out.

If you can break open the amp and see inside that helps to spot obvious damage. I would be careful though as there are heat pads on some components to transfer heat from hot components to amp case. Don't want to break those.

The fact that MMI still works and things still function - except sound - points to the amp at the moment.

You may be able to find a working amp on fleabay and swap it out. It will still work but no with all channels. You can take to an independent (or someone with VCDS) and get it 'coded' to your car.

Apologies i can't help more. I feel your pain as i've been there!
 

·
Premium Member
Joined
·
3,266 Posts
Please don't pay so much without seeing and touching what you have been charged for!!! I agree, purchase another amp and swap it over. Good luck and tell us your findings please!!
 
  • Like
Reactions: TTS001
1 - 5 of 5 Posts
Top