Audi A5 Forum & Audi S5 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi
I have a 2010 A5 2 litre diesel which was suffering from signs of a failed thermostat. I have had the same replaced, but the car is still taking forever to reach temperature (I have just driven 23 miles to work and the gauge reached just over 1/4 way).
Could the new stat be faulty or should I be checking elsewhere?
 

·
Premium Member
Joined
·
3,266 Posts
Malcolm mate, VW Audi has a long history of having these made by Tom Dick and Harry in their sheds and the quality is often crap. Did you fit a good one or a pattern one, which could be even worse?? The easiest option is to replace it again with the best one you can find (OEM like Bosch or similar) and try the car, this could resolve your problem for 30 quid.

If not then make a check with VCDS and see if you have other errors,,,,,
 

·
Premium Member
Joined
·
3,266 Posts
Ps why such a quality car company slips up on a cheap but vital metal part is truly WIERD eh??
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Thanks for the reply.
The stat was fitted by a local Audi independent specialist as we are in the throes of moving and all the tools are packed away. I am sure it was an aftermarket one. Strange it seems to vary as going into work today it behaved perfectly aside from being a bit slow to warm up. An airlock wouldn’t cause an issue would it?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
The mechanic said when I collected the car he was not sure if it was fully ok. He ran diagnostics but couldn’t find anything
 
1 - 6 of 6 Posts
Top