Audi A5 Forum & Audi S5 Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hello all. heres what i got. vehicle ran when i got it. just engine noise. replaced the engine. i have the same battery that it came with, even a new one i tried. heres what i got. 1)key fob is stuck in ignition, wont release. 2) push start button, nothing comes on. no dash lights, no crank, nada! 3) i have headlights, brake lights. 4) trunk wont even close because of elctric lock 5) cannot release the eletric brakes, so i cant even push the car
checked all fuses and relays. good
checked all ground, good
all connections are good. fuses for comfort control module good. im all out of options now. have no idea were to go from here. help please!!!
 

·
Registered
Joined
·
1,421 Posts
Looks like you have overlooked a ground or power connection somewhere. Check the main fuses under the windshield. There is also a ground point just by there as well that can get missed
 
  • Like
Reactions: SimonRoma

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
i will triple check all power and grounds again. not many grounds on this thing. all the fuses under the windshield are good.
also, im not able to communicate with any modules, so i cannot get any codes. i am getting power to the dlc though.
 

·
Registered
2014 A4Q/8K 6MT MMI 3G+
Joined
·
441 Posts
@southwestern : Do you have the proper wiring diagrams for your 2009 A5 ? If not, sign up at erwin.audiusa.com for the $35 24-hour subscription and download EVERYTHING for your car, including all PDF repair manuals, wiring diagrams, TSBs, etc. --g
 

·
Registered
Joined
·
1,421 Posts
Noooo, unless you have mismatched keys and ecus etc then yes but not just an engine swap. Have you gone through the fuses and wiring connection points in box under the ecu? Defo must me a wire not connected or a ground
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
i went through all the fuses. under pcm, in trunk, both sides of dash. i checked the #5 fuse on passenge side, data bus diagnostic interface board, that has power.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
thank you DrGer. that helped alot. I got a used comfort control module. now, when i open the door, i get mileage on the dash. i get to take the key out, which i wasnt able to do before. im still not starting. but atleast im getting communication with modules now. so i think maybe it needs to be programed.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
so my guy came with his fancy computer. he said its still not powering up to communicate with the comfort control module. he says he can communicate with the abs and instrument cluster module but thats all. the dash says switch to park, i have a manual transmission. i firgured this used one came from an automatic. any suggestions from here?
atleast now i got the fob out of the dash, and when i open the door the center mesage center comes on, with the mileage and that note about putting it into park
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
also forgot to mention. when i plug in my scan tool, i have an autel maxicom. i do an auto scan, and it shows 9 codes in the comfort control module, but when i try to get a reading on the codes, it wont show me
 

·
Registered
Joined
·
131 Posts
It sounds like you need vcds and then rhe long coding option to program up the CCM with the codes that make sense to your car..


Sent from my SM-G985F using Tapatalk
 
1 - 15 of 15 Posts
Top