Emission control system warning light came on today - A5_OC


Go Back   A5_OC > Audi A5 & Audi S5 Forums > A5 & S5 Topics

Reply
 
LinkBack Thread Tools Display Modes
Old 28th October 2008, 04:30 AM   #1
Member
 
Join Date: Sep 2008
Location: UK
Posts: 61
Potemkin is on a distinguished road
Send a message via ICQ to Potemkin
Default Emission control system warning light came on today

Cold today, really frosty. I let the car warm up on the drive, then drove off. The orange Emission control system light came and stayed on. I didn't notice any unusual behaviour, other than the light, but I pulled over and consulted my manual. It seems this usually happens when driving only short journeys, when the emissions system doesn't get hot enough to burn off all the soot n' stuff. However, I've been doing about 500 miles a week in my A5, so I doubt this was the problem.

The only thing I can think of:
1. The cold weather is the cause
2. This is my first tank of BP "ultimate" diesel - perhaps this a factor?
3. Something has failed on my exhaust system.

I rang my local Audi garage, who said it's probably no biggie. I've booked the car in for a week's time. I'll let you know what they find, in case this affects other A5 owners in the cold weather ahead....



_______
A5 3.0TDI Quattro; UK; 19" Y Wheels; Sports suspension; hot seats; cruise control; bluetooth; Big Grin
Potemkin is offline   Reply With Quote Quick reply to this message
Sponsor - Register now for free to stop viewing this ad.
Old 2nd November 2008, 11:04 PM   #2
Member
 
Join Date: Jul 2007
Location: Cheshire UK
Posts: 39
auriga is on a distinguished road
Default

I had the yellow warning light flashing this morning when I started the car, not a particularly cold morning although the car had not moved since friday, very lumpy on start up but settled down after 30 seconds and the light stopped flashing.

Have you had any more feedback from Audi as to the possible casue?
auriga is offline   Reply With Quote Quick reply to this message
Old 2nd November 2008, 11:29 PM   #3
Senior Member
 
Booster's Avatar
 
Join Date: Apr 2008
Location: UK
Posts: 479
Booster is on a distinguished road
Default

See this thread:

http://www.a5oc.com/forums/showthrea...679/index.html

Mine is going in on wednesday.

Will let you know what they say.

Car is still driving fine (although may be a bit reluctant to change up and quick to change down - but that could be be looking for faults!!)



2009 model A5 3.0TDi Quattro Sport Tiptronic, Quartz grey, Black Valcona, Nav, B+O, 19" Y's, AMI, Cruise, Advanced parking, Comfort pack, Interior light pack, Bluetooth low, Black headlining
Booster is offline   Reply With Quote Quick reply to this message
Old 3rd November 2008, 04:22 AM   #4
Member
 
Join Date: Jul 2007
Location: Cheshire UK
Posts: 39
auriga is on a distinguished road
Default

Mine is an S5 and I have had the niggling feeling that the car isnt quite right for a few weeks, at lower speeds it seems a little lumpy especially when accelerating in a higher gear, I have put it down to just being in to high a gear - e.g. 30 mph in 6th, seems ok when the speed increases. i have been cheaking the oil as i thought this might be the problem but the oil has not moved for the last 5 months, this and the fact that my economy is decreasing makes me think I have the start of a problem.

I have not contacted Audi as I dont have a tangible problem yet, will certainly call if it flashes again.

Last edited by auriga; 3rd November 2008 at 04:25 AM. Reason: spelling
auriga is offline   Reply With Quote Quick reply to this message
Old 6th November 2008, 08:21 AM   #5
Member
 
Join Date: Sep 2008
Location: UK
Posts: 61
Potemkin is on a distinguished road
Send a message via ICQ to Potemkin
Default No answer yet..

So, Audi Aylesbury is coming to pick up my A5 on Tuesday. I'll let you know what they say.

Meanwhile, I left the car in the driveway for a couple of days (during which the weather warmed), then hey presto! No more warning light.



_______
A5 3.0TDI Quattro; UK; 19" Y Wheels; Sports suspension; hot seats; cruise control; bluetooth; Big Grin
Potemkin is offline   Reply With Quote Quick reply to this message
Old 7th November 2008, 04:24 AM   #6
Member
 
stevesks's Avatar
 
Join Date: Feb 2008
Location: Sheffield UK
Posts: 36
stevesks is on a distinguished road
Default

Mine came on the other week. I was in a drive thru car wash!! (shock horror but mine's white and shows the dirt soooo much this time of year). Anyway I'd switched the ignition off and was listening to music. When I tried to re-start the engine, the rev counter and speedo needles shot round to 3 oclock as normal but the engine didn't turn and the light came on! Tried a couple of times with no joy and started to sweat a little due to the queue that had formed behind me. Only after completely removing the key from the dash and trying to start up again sorted the problem. Hasn't happened since. Anyone else????



1.8T Ibis White, Pale Grey, Xenons/DRLs + mods, DVD Sat Nav, 20mm custom spacers all round.
stevesks is offline   Reply With Quote Quick reply to this message
Old 7th November 2008, 06:31 AM   #7
Senior Member
 
Join Date: Sep 2007
Location: Berkshire
Posts: 171
prhim is on a distinguished road
Default

Funnily enough, mine came on this week, on my way home from Manchester.

My car was already booked into Newbury Audi for them to investigate the vibration issue, so they just got another thing to look at!

I noticed on the service form that they were also undertaking three service items / recalls - something to do with battery management, one to do with a fuel line and something else I can't now remember.



A5 3.0 TDi Sport, 19" S5 Alloys with 25mm drop and 15mm spacers, Adaptive Lights, Alu Inserts, AMI, B&0, Black Milano, Advanced Parking Plus, Sat Nav, DAB & TV, Milltek Exhaust
prhim is offline   Reply With Quote Quick reply to this message
Old 7th November 2008, 10:13 AM   #8
Senior Member
 
Booster's Avatar
 
Join Date: Apr 2008
Location: UK
Posts: 479
Booster is on a distinguished road
Default

Mine went in on wednesday. It is the secondary water pump. It has an intermittent fault and needs to be replaced. Part is on back order and will be delivered in a fortnight. Car is fine to dsrive till then they tell me.



2009 model A5 3.0TDi Quattro Sport Tiptronic, Quartz grey, Black Valcona, Nav, B+O, 19" Y's, AMI, Cruise, Advanced parking, Comfort pack, Interior light pack, Bluetooth low, Black headlining
Booster is offline   Reply With Quote Quick reply to this message
Old 15th November 2008, 01:38 AM   #9
Member
 
Join Date: Sep 2008
Location: UK
Posts: 61
Potemkin is on a distinguished road
Send a message via ICQ to Potemkin
Default No fault found

Audi Aylesbury report on my car:

"Engine management light on, no running faults. Carried out guided fault finding, tested air mass meter and air temp sender. Cancelled faults and rad tested. No parts used."

Seems as though they couldn't find anything wrong. No mention of secondary water pumps, etc.

Incidentally, they also carried out the following two recalls:

Recall 20P2 renewing fuel hose. Parts fitted: rep. set, washer
Recall 27C5 reparing earth wire. No parts used



_______
A5 3.0TDI Quattro; UK; 19" Y Wheels; Sports suspension; hot seats; cruise control; bluetooth; Big Grin

Last edited by Potemkin; 15th November 2008 at 01:43 AM.
Potemkin is offline   Reply With Quote Quick reply to this message
Old 16th November 2008, 11:20 PM   #10
Member
 
Join Date: Sep 2008
Location: UK
Posts: 61
Potemkin is on a distinguished road
Send a message via ICQ to Potemkin
Default here we go again

Frosty again today, and guess what? Yup, emissions warning light staring at me from the dash - a steady gaze that tells me audi aylesbury will be taking the car back in very shortly.

I will tell them to check the secondary water pump thingie.



_______
A5 3.0TDI Quattro; UK; 19" Y Wheels; Sports suspension; hot seats; cruise control; bluetooth; Big Grin
Potemkin is offline   Reply With Quote Quick reply to this message
Old 17th November 2008, 04:23 AM   #11
Senior Member
 
Join Date: Sep 2007
Location: Berkshire
Posts: 171
prhim is on a distinguished road
Default

According to my dealer, my emissions light coming on was caused by the airbox becoming full of leaves... Not entirely clear how that happened, but hey, at least it wasn't anything too serious.



A5 3.0 TDi Sport, 19" S5 Alloys with 25mm drop and 15mm spacers, Adaptive Lights, Alu Inserts, AMI, B&0, Black Milano, Advanced Parking Plus, Sat Nav, DAB & TV, Milltek Exhaust
prhim is offline   Reply With Quote Quick reply to this message
Old 18th November 2008, 12:59 AM   #12
Junior Member
 
Join Date: Nov 2007
Location: London
Posts: 2
David is on a distinguished road
Default Warning lights

In recent weeks the emission control warning light in my S5 has come on and remained on twice, with no fault being identified by the dealership when I took it in. Most recently I had the parking break and ESP warning lights come on, and remain on.

Docklands Audi checked it out for me and again said there was nothing wrong with the car that they could see, although from the readouts they had they did say although this time it was a different set of warning lights, it was being triggered by the same issue as for the previous warning lights. They were stumped and passed the details on the Audi Technical, and were told of a known problem to do with air getting into the emissions system, and they did need to install a new part to sort it out. This has now happened - my fourth trip to Docklands Audi in about a month. I am off on a long drive this weekend and will see if any more warning lights come on.

At no point has there been anything wrong with the car that I noticed, other than the warning lights coming on.
David is offline   Reply With Quote Quick reply to this message
Old 27th November 2008, 04:00 AM   #13
Member
 
Join Date: Sep 2008
Location: UK
Posts: 61
Potemkin is on a distinguished road
Send a message via ICQ to Potemkin
Default Fixed?

Well, whilst waiting for Audi Aylesbury to pick up my A5 again, the light went off again. It really seemed to only come on when there was frost.
Anyway, the dealership kept it in for a couple of days, and replaced the "air temperature sensor". This seems to have fixed it, but then again there hasn't been any frost since I got the car back.

BTW, Aylesbury Audi have been consistently helpful, and they provide a free tin of Audi-branded sweeties when they return the car. Small touch, but appreciated.



_______
A5 3.0TDI Quattro; UK; 19" Y Wheels; Sports suspension; hot seats; cruise control; bluetooth; Big Grin
Potemkin is offline   Reply With Quote Quick reply to this message
Old 16th January 2009, 09:54 PM   #14
Junior Member
 
Join Date: Nov 2008
Location: Sydney, Australia
Posts: 17
Schmick is on a distinguished road
Default

Hey fellas,

Ah! Took delivery of my A5 just TWO days ago, and now i got this annoying yellow emissions control light on my dashboard and I'm less than impressed.

I'm all the way in Sydney and the past two days have been scorchers - 30 degrees celsius..so i don't think i'm having the same 'frosty' problem as you guys

Anyone know if the manual advice works? (i.e. drive it at like 60km/hr at 2000rpm for 15mins to burn off the soot)

Gonna give my dealer a call tmrw and see what he has to say about it!
Schmick is offline   Reply With Quote Quick reply to this message
Old 17th January 2009, 03:02 AM   #15
Super Moderator
 
Rab88's Avatar
 
Join Date: Aug 2007
Location: Glasgow, Scotland.
Posts: 1,807
Rab88 is on a distinguished road
Default

Quote:
Originally Posted by Schmick View Post
Anyone know if the manual advice works? (i.e. drive it at like 60km/hr at 2000rpm for 15mins to burn off the soot)
Yes, it works. It's normal for diesels to get a build up in the particulate filter if you only do short, slow journeys. You shouldn't really buy a diesel if that's what you normally do.

I also had the warning on the dash when I'd been driving the car less over a few days. Then the morning after on my way to edinburgh the warning went away, as the soot had burnt off.

If the warning doesn't go away, audi will certainly clean the filter for you if it's too clogged up to clean itself.



A5OC Moderator
Rab88 is offline   Reply With Quote Quick reply to this message
Old 8th February 2009, 03:12 AM   #16
Junior Member
 
Join Date: Jun 2008
Location: Helsinki, Finland
Posts: 3
Xone is on a distinguished road
Default

Emission control warning light came on for me as well. I tried first the normal procedure to clean the clogged DPF, but that didn't help. Next morning I went to local dealers express service. After diagnostics it turned out to be faulty intake air temperature sensor.

I think it has been at least partly broken for longer while. The symptoms before warning light were:
- slightly different engine sound (more old fashion diesel)
- ~0.5l/100km more consumption on extra urban roads
- sluggish throttle response on low revs (1200-1500rpm). This I found out only after repair - engine much more lively.

Last but not the least I have to mention that service was pretty excellent on Audi Center Helsinki express service - I even got small breakfast while waiting for diagnostics. This customer care experience made me feeling MUCH better after annoying warning lights
Xone is offline   Reply With Quote Quick reply to this message
Old 21st March 2009, 12:52 AM   #17
Senior Member
 
Booster's Avatar
 
Join Date: Apr 2008
Location: UK
Posts: 479
Booster is on a distinguished road
Default

Bugger. Engine management light came on again yesterday. Really haven't got the time to get it to Audi this week



2009 model A5 3.0TDi Quattro Sport Tiptronic, Quartz grey, Black Valcona, Nav, B+O, 19" Y's, AMI, Cruise, Advanced parking, Comfort pack, Interior light pack, Bluetooth low, Black headlining
Booster is offline   Reply With Quote Quick reply to this message
Old 4th June 2009, 12:24 AM   #18
Junior Member
 
Join Date: Jan 2009
Posts: 2
demps77 is on a distinguished road
Default Aaaaaaahhhhhh

I've had an on-going problem with mine for 3 months now. Today was the 4th time I have taken my car into Bristol Audi in 6 weeks.....

I usually only drive 4 or 5 miles to work 3 days a week and a long trip once or twice a week. The Particulate Filter light comes on usually once on every trip, even after the long trips. First time Audi said they had reset the light, second time they "said" they had replaced it, 3rd time they said it was a software update...... So I'll keep you updated as to what they come back with this time!!

When I dropped it off this morning the DPF light was on, the glow plug was flashing and the engine management light was on.... Me thinks my car has got swine flu!!
demps77 is offline   Reply With Quote Quick reply to this message
Old 4th June 2009, 12:50 AM   #19
Senior Member
 
Booster's Avatar
 
Join Date: Apr 2008
Location: UK
Posts: 479
Booster is on a distinguished road
Default

Had mine sorted and they said it was a software update....



2009 model A5 3.0TDi Quattro Sport Tiptronic, Quartz grey, Black Valcona, Nav, B+O, 19" Y's, AMI, Cruise, Advanced parking, Comfort pack, Interior light pack, Bluetooth low, Black headlining
Booster is offline   Reply With Quote Quick reply to this message
Old 28th August 2009, 03:22 AM   #20
Junior Member
 
Join Date: Apr 2009
Location: Cirencester UK
Posts: 26
Johnsc is on a distinguished road
Default

Had the yellow outline management lamp come on (Stays on) at 6K miles on June 09 model. Have been told it needs a new, modified auxilliary coolant pump. Goes in next week but ok to drive as normal until then!!



A5 2.7 S Line BB, s-line suspension, 5 spoke 18", 3G MMI with Low phone, full e- and heated seats,B&O,Adapt lights,Adv key,TPM.
Johnsc is offline   Reply With Quote Quick reply to this message
Old 31st March 2010, 03:38 AM   #21
Member
 
Join Date: Sep 2008
Location: UK
Posts: 61
Potemkin is on a distinguished road
Send a message via ICQ to Potemkin
Default Light came on AGAIN

Well, had a weird problem this month. Fuel gauge and fuel range went to zero, despite having a full tank. Car sounded a bit "wrong" and I could detect a burning rubber smell around the rear of the car occasionally. I booked it in for a service.

A couple of days before the appointment the car went into "limp" mode and the Diesel Particulate Filter warning light came on. This happened once before, about 18 months ago, and the DPF sensor was replaced at that time.

Anyway, this time around, Audi Roadside came out and diagnosed "multiple faults" with the system that controls "everything except the engine". Limped to the dealership, who spent two weeks trying to diagnose the issue. Apparently they were having problems installing a software update (no idea which one). Curiously, when I picked it up, the only thing listed on the worksheet was a replacement DPF sensor (again!). Seems these fail quite often.

Not sure what else was wrong or fixed, but all symptoms disappeared, and fuel gauge working again. Milton Keynes Audi (not my favourite, but they were the closest at the time of the breakdown).

I do mostly motorway miles, so DPF gets up to temperature.



_______
A5 3.0TDI Quattro; UK; 19" Y Wheels; Sports suspension; hot seats; cruise control; bluetooth; Big Grin

Last edited by Potemkin; 31st March 2010 at 03:40 AM. Reason: Typo
Potemkin is offline   Reply With Quote Quick reply to this message
Old 26th March 2013, 12:29 AM   #22
Junior Member
 
Join Date: Apr 2011
Posts: 6
ninesixty8 is on a distinguished road
Default ECS Fault Light

Quote:
Originally Posted by auriga View Post
Mine is an S5 and I have had the niggling feeling that the car isnt quite right for a few weeks, at lower speeds it seems a little lumpy especially when accelerating in a higher gear, I have put it down to just being in to high a gear - e.g. 30 mph in 6th, seems ok when the speed increases. i have been cheaking the oil as i thought this might be the problem but the oil has not moved for the last 5 months, this and the fact that my economy is decreasing makes me think I have the start of a problem.

I have not contacted Audi as I dont have a tangible problem yet, will certainly call if it flashes again.
Hi Auriga,

I dug up an old post of yours as my car is exhibiting the exact same behaviour as you have described above. My local specialist reckons I need to replace the catalytic converters to fix the problem.

Just wanted to find out what was the cause of the issue and how did you end up fixing it?


Thanks!
ninesixty8 is offline   Reply With Quote Quick reply to this message
Old 18th October 2013, 06:11 PM   #23
Junior Member
 
Join Date: Oct 2013
Posts: 6
teejahsmith is on a distinguished road
Default

I recently had a full service and mot on my Audi A5 3.0 tdi quattro at my local audi dealership. Today I had the particulate filter light come on, then the glow plug light starts flashing now when I turn the engine on the engine management light is on. Whats wrong with my baby???
teejahsmith is offline   Reply With Quote Quick reply to this message
Old 30th December 2013, 12:43 PM   #24
Junior Member
 
Join Date: Oct 2013
Posts: 17
trishup is on a distinguished road
Default

my car is drinking alot of engine oil, so i called my local Audi dealership and they booked the car in for this friday, however when I was driving home from work later on today my emission control system light came on, and now wont go away!!!

i bought this car as 2nd hand only a few months and the engine oil issue is just ridiculous, just got the car service last week and now this! i hope there is nothing serious, otherwise i have wasted my money away!

i must be the first person to say that i cant enjoy my Audi A5! after years of eyeing up this car, i finally got one and now all this
trishup is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the A5_OC forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:57 AM.


SEO by vBSEO 3.6.0